moronhead

Well-Known Member
Aug 12, 2001
706
0
316
I am curious if anyone knows if there are any size restrictions for email attachments either sent through or received by a Cpanel server.

I've had a client complaining that:

1. The size of the file is increased by about 30%; and

2. The attachment note says x of 2MB.

Does this mean that the maximum attachment to any one e-mail is 2MB?

If so, how can this be adjusted?
 
B

bdraco

Guest
[quote:2c0230d0d5][i:2c0230d0d5]Originally posted by moronhead[/i:2c0230d0d5]

I am curious if anyone knows if there are any size restrictions for email attachments either sent through or received by a Cpanel server.

I've had a client complaining that:

1. The size of the file is increased by about 30%; and

2. The attachment note says x of 2MB.

Does this mean that the maximum attachment to any one e-mail is 2MB?

If so, how can this be adjusted?[/quote:2c0230d0d5]

Check the message_size_limit in your exim.conf .. cpanel doesn't set one by default so you should be able to send any size. (check /var/log/exim_rejectlog for more info)


message_size_limit

Type: integer
Default: 0

This option limits the maximum size of message that Exim will process. Zero means no limit. It should be set somewhat larger than return_size_limit if the latter is non-zero. Incoming SMTP messages are failed with a 552 error if the limit is exceeded; locally-generated messages either get a stderr message or a delivery failure message to the sender, depending on the -oe setting, in the normal way. Rejection of an oversized message is logged in both the main and the reject logs. See also the generic transport option message_size_limit, which limits the size of message that an individual transport can process.
 

moronhead

Well-Known Member
Aug 12, 2001
706
0
316
[quote:6c1a08eb99][i:6c1a08eb99]Originally posted by bdraco[/i:6c1a08eb99]

Check the message_size_limit in your exim.conf .. cpanel doesn't set one by default so you should be able to send any size. (check /var/log/exim_rejectlog for more info)

message_size_limit

Type: integer
Default: 0

This option limits the maximum size of message that Exim will process. Zero means no limit. It should be set somewhat larger than return_size_limit if the latter is non-zero. Incoming SMTP messages are failed with a 552 error if the limit is exceeded; locally-generated messages either get a stderr message or a delivery failure message to the sender, depending on the -oe setting, in the normal way. Rejection of an oversized message is logged in both the main and the reject logs. See also the generic transport option message_size_limit, which limits the size of message that an individual transport can process. [/quote:6c1a08eb99]
I've added

message_size_limit = 16384000

return_size_limit = 65536

and restarted exim.

I'll monitor results and report back.
 

moronhead

Well-Known Member
Aug 12, 2001
706
0
316
Confirmed: The reported size of emails don't seem to match the amount of data sent and retrieved. For instance:

* Email with a single paragraph of text (less than 1 KB when sent w/o attachment) and a 54 KB attachment shows up as 74 KB when sent through mail.userdomain.com and when retrieved by Outlook Express.

* The same email with a 3.10 MB attachment shows up as 246 KB when sent and as 4.24 MB when retrieved.

What's causing this?
 

Brad

Well-Known Member
Aug 16, 2001
231
0
316
Are you taking into account the size increase by mailers after mime encoding attachments?

This doesn't seem right for the sent..

& * The same email with a 3.10 MB attachment shows up as 246 KB when sent and as 4.24 MB when retrieved.
 

moronhead

Well-Known Member
Aug 12, 2001
706
0
316
[quote:c2cf13f2b6][i:c2cf13f2b6]Originally posted by Brad[/i:c2cf13f2b6]

Are you taking into account the size increase by mailers after mime encoding attachments?

This doesn't seem right for the sent..

& * The same email with a 3.10 MB attachment shows up as 246 KB when sent and as 4.24 MB when retrieved.
[/quote:c2cf13f2b6]
Thanks Brad. The encoding must be what's causing the increase in the file size. This is not a cpanel issue. Sending the same attachment via mail.domain.com and through my ISP's mail server resulted in the same file size.

The 246 KB was the size that Opera 6.01 reported. Outlook Express is reporting it correctly as 4.24 MB.
 

aromalp

Member
Jul 15, 2004
10
1
151
Mail attachments

/usr/local/cpanel/etc/neomail.conf set variable $attlimit = N; where N is the required limit of attachments in MB. :eek: