The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain and IP not working

Discussion in 'General Discussion' started by imagic, May 12, 2003.

  1. imagic

    imagic Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Can anybody give me some idea of what the solution for this is:

    Last night about 7 accounts stopped working. Neither the domain name nor the IP address is accessible via http, you get a 404 error. The other accounts on the server are working fine.

    We restarted bind and apache, neither helped.

    We're using WHM 6.2.0 Cpanel 6.4.0-S16 RedHat 8.0

    The IPs and domains are pinging, however through dnsstuff.com, the domain is getting [Destination Unreachable][Missing reverse DNS entry]

    An example of one of the domains:
    vmc-sat.com - 162.42.214.41

    Thank you for any assistance you can provide.
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    A couple of observations, no cname records. Not a big deal though, just www won't work.

    Looking further down at the service scan there seems to be no http nor ftp service on this ip. First round. Is the IP correct? Is there a Virtual Host entry for this IP in httpd.conf?



    Address lookup
    canonical name vmc-sat.com.
    aliases
    addresses 162.42.214.41


    DNS records
    name class type data time to live
    vmc-sat.com IN NS ns1.hosteddomain.com 86400s (1d)
    vmc-sat.com IN NS ns2.hosteddomain.com 86400s (1d)
    vmc-sat.com IN A 162.42.214.41 14400s (4h)
    vmc-sat.com IN MX preference: 0
    exchange: vmc-sat.com
    14400s (4h)
    vmc-sat.com IN SOA server: ns1.hosteddomain.com
    email: root@host2.hosteddomain.com
    serial: 1052411256
    refresh: 28800
    retry: 7200
    expire: 3600000
    minimum ttl: 86400
    14400s (4h)

    Service scan
    FTP - 21 Error: Timed out
    SMTP - 25 220-host2.hosteddomain.com ESMTP Exim 3.36 #1 Mon, 12 May 2003 11:55:15 -0700
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    HTTP - 80 Error: Timed out
    POP3 - 110 +OK POP3 [DarkORB cppop 3.0] at [162.42.214.41]
    NNTP - 119 Error: Connection refused
     
  3. imagic

    imagic Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    156
    Likes Received:
    0
    Trophy Points:
    16
    David,

    Thanks as usual for your help.

    The IP is correct and there is a virtualhost entry in httpd.conf for it. What's weird is that they were working for 2 days and just last night stopped working.

    Any other ideas?

    Shouldn't Cpanel be automatically creating a cname for www?

    Thanks again.
     
  4. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Yes cpanel should be creating the www cname and the mail and ftp ones as well.

    See what is strange is that even putting the IP in your browser you do not get to Apache. You should get something on there, that tells me apache is not talking on the IP.

    So I would look at an IP issue, has the IP been hijacked? If you down and up the eth for it does it fix anything?

    I know it sounds strange but I had a client with similar issue, the IP in that case was showing a site that wasn't even on his servers. The IP was also in use by another and it got there first.
     
Loading...

Share This Page