The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

domain.com/cgi-sys/defaultwebpage.cgi shows instead of website on new server

Discussion in 'General Discussion' started by TheDjinn, Mar 3, 2016.

  1. TheDjinn

    TheDjinn Member

    Joined:
    Dec 9, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi everyone, I recently purchased space on a new VPS server since my first one was getting a bit full. Everything went well with the install and I didn't seem to have any issues setting it up and securing it. However I noticed a very strange issue.

    Whenever I create an account and install Wordpress, or even load a simple index.html page to public_html I always get domain.com/cgi-sys/defaultwebpage.cgi. Doesn't matter which account I use.

    I checked the error logs on the domain and it was blank. I'm sure there has to be something misconfigured but it's escaping me.

    Here is my server information:

    Code:
    /etc/redhat-release:CloudLinux release 7.2 (Valeri Kubasov)
    /usr/local/cpanel/version:11.54.0.18
    /var/cpanel/envtype:kvm
    CPANEL=release
    Server version: Apache/2.4.18 (Unix)
    Server built:   Mar  2 2016 22:49:25
    Cpanel::Easy::Apache v3.32.10 rev9999 +cloudlinux
    PHP 5.5.32 (cli) (built: Mar  2 2016 22:53:07)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
    mysql  Ver 14.14 Distrib 5.5.48, for Linux (x86_64) using readline 5.1
    Any help would be greatly appreciated!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Check to verify if the domain name resolves to the same IP address that it's assigned in Web Host Manager. If it is, check to see if running the following command addresses the issue:

    Code:
    /scripts/rebuildhttpdconf
    If the issue persists, could you let us know if you have enabled 1:1 NAT on this system?

    Thank you.
     
  3. TheDjinn

    TheDjinn Member

    Joined:
    Dec 9, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    That's what it was. I had added DDOS protection to the server and received a new IP address I needed to set as the main shared IP.

    Thanks Michael,
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page