The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

domain.com/cpanel not redirecting correctly

Discussion in 'Bind / DNS / Nameserver Issues' started by Mike0111, Nov 10, 2015.

  1. Mike0111

    Mike0111 Registered

    Joined:
    Nov 10, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    domain.com/cpanel is supposed to redirect to IPADDRESS:2083 (eg: 123.123.123.123:2083)
    ...but instead it redirects to hostname:2083
    ...and I get the error: "This webpage is not available" (in Chrome).

    Tweak->Redirection-> Always redirect to SSL:ON
    If I manually type IPADDRESS:2083 it works fine, and if I access from the WHM shortcut it works fine, too.

    This is a GoDaddy V-dad server.
    I have another that works correctly, and I've compared all the settings between the two.

    Thanks for your help!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can modify the settings under the "Redirection" tab in "WHM >> Tweak Settings" to change the redirect behavior, however note that none of the options include redirecting to the IP address itself in the address bar.

    Thank you.
     
  3. Mike0111

    Mike0111 Registered

    Joined:
    Nov 10, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    I don't understand...there are only 2 options on my screen, and the second option is for "logout" not login.

    Also, as I mentioned, I have another identical system and the settings are exactly as shown here and it works perfectly.
    2 cPanel systems configured exactly the same. One correctly redirects to the IP:PORT and it works perfectly as outlined in the cPanel manual. The other redirects to the HOSTNAME:PORT and it does not work at all.

    As a sidenote, before posting I tried turning the SSL option off and playing with various options here but nothing worked...and I don't like the idea of a non-SSL connection, especially since it works perfectly on another with this exact configuration.

    redirectionmk01111.jpg
     
    #3 Mike0111, Nov 11, 2015
    Last edited by a moderator: Nov 11, 2015
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Per the option description, when "Always redirect to SSL" is enabled:

    Always redirect users to the SSL/TLS ports and certificate hostname when visiting /cpanel, /webmail, etc.

    The certificate for the cPanel/WHM service is installed at:

    "WHM Home » Service Configuration » Manage Service SSL Certificates"

    Is the hostname or certificate name on the other service configured any differently?

    Thank you.
     
Loading...

Share This Page