Domain has exceeded the max defers and failures per hour (5/5 (100%))

brownsmart

Member
Jan 9, 2013
6
0
1
cPanel Access Level
Root Administrator
Hi guys,

2 Problems I have

1. The past few days I have been getting a lot of emails from client saying they cant send emails and when they do they get this message:

Domain domainhere.org has exceeded the max defers and failures per hour (5/5 (100%)) allowed. Message discarded.
There where no limits set up to begin with, basic packages with unlimited emails per hour.

I have found the post that explains "/var/cpanel/email_send_limits/" and deleting the max_deferail_domain. file but it keeps coming back after a few minutes.


2. Mail Queue Manager:

Unable to deliver emails and get "No Route To Host" error message on all the emails I try to push along in the queue.

Some advice would be much appreciated, I have also opened a ticket about this issue!
 

celiac101

Well-Known Member
Dec 19, 2012
85
1
8
cPanel Access Level
Website Owner
This is happening to me also. I have tried everything. I originally set tweak settings maxemailsperhour to 25%, then changed to unlimited, but the block keeps happening. I even deleted the max_deferfail_domain.com file created in /var/cpanel/email_send_limits/ but it keeps getting re-created. I may resort to a cron running every minute to delete this file...help!
 

celiac101

Well-Known Member
Dec 19, 2012
85
1
8
cPanel Access Level
Website Owner
FYI: I have a 2nd cpanel server and found that in the files under /var/cpanel/email_send_limits/cache they have "0" and don't have any issues, where the problem server has "unlimited". I have changed this to see if it works, but to me it looks like a bug.
 

celiac101

Well-Known Member
Dec 19, 2012
85
1
8
cPanel Access Level
Website Owner
This did not work...the file keeps coming back and deletes all email sent by the domain...
 
Last edited:

celiac101

Well-Known Member
Dec 19, 2012
85
1
8
cPanel Access Level
Website Owner
I think I finally figured this out, and want to help the next poor person afflicted by this. I to still think it is a bug, but you decide. My ISP who put this server together put in a bad DNS entry in /etc/resolv.conf, or their DNS just has issues...not sure which. So I had my two DNS server IP's and their bad on in that file for "nameserver" in that file. Once I replaced their DNS entry with google's 8.8.8.8 everything worked fine, and the blocks stopped happening.

Now here is the question. If I mark the percentage of bounce emails per domain to unlimited in Tweak Settings, which I did, this block still should not take place. Unlimited should mean unlimited. I think this is a Cpanel bug.