The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain jumping to old nameserver

Discussion in 'Bind / DNS / Nameserver Issues' started by beservers, Sep 12, 2010.

  1. beservers

    beservers Registered

    Joined:
    Sep 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have a strange problem with one of my customers domains.
    We transfered the domain svagroup.org and website to our servers from their former host who used also Cpanel. It was done in Cpanel (backup) and restored in WHM.

    No problem at this point.


    The domain is now on our nameservers for 5 days and the website and especially the subdomains are jumping between our server ip and the server of their old host.

    Anybody had this problem? dns caching for more than 5 days is a little strange.

    Example for the subdomain, nslookup is pointing to the correct one 62.182.57.115 and the ping to their former host.

    C:\>nslookup svagroup.org
    Server: hobo.dnscache02.telenet-ops.be
    Address: 195.130.131.4

    Non-authoritative answer:
    Name: svagroup.org
    Address: 62.182.57.115


    C:\>ping aeroclub.svagroup.org

    Pingen naar aeroclub.svagroup.org [85.234.141.93] met 32 byte gegevens:

    Antwoord van 85.234.141.93: bytes=32 tijd=20 ms TTL=56
    Antwoord van 85.234.141.93: bytes=32 tijd=21 ms TTL=56
    Antwoord van 85.234.141.93: bytes=32 tijd=21 ms TTL=56
    Antwoord van 85.234.141.93: bytes=32 tijd=21 ms TTL=56

    Ping-statistieken voor 85.234.141.93:
    Pakketten: verzonden = 4, ontvangen = 4, verloren = 0
    (0% verlies).De gemiddelde tijd voor het uitvoeren van één bewerking in mill
    iseconden:
    Minimum = 20ms, Maximum = 21ms, Gemiddelde = 20ms


    C:\>nslookup aeroclub.svagroup.org
    Server: hobo.dnscache02.telenet-ops.be
    Address: 195.130.131.4

    Non-authoritative answer:
    Name: aeroclub.svagroup.org
    Address: 62.182.57.115
     
    #1 beservers, Sep 12, 2010
    Last edited: Sep 12, 2010
  2. rackaid

    rackaid Active Member

    Joined:
    Jan 18, 2003
    Messages:
    42
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Jacksonville, FL
    cPanel Access Level:
    DataCenter Provider
    This can happen for a few reasons. I've listed them in the order you may want to check.

    Local Caching:
    Rule out local caching for yourself and client. Be sure to restart any local DNS servers.


    Zone Issues:
    Doublecheck the zones on your server. Make sure you do not have a eroclub.svagroup.org or other subdomain.domain.com type zones that have the old IP addresses.


    Nameserver issues:
    I show these as the nameservers:
    ns2.beservers.be. [62.182.57.116
    ns1.beservers.be. [62.182.57.115
    ns3.beservers.be. [213.163.66.231

    Query each nameserver directly for the problem record:

    Code:
    dig @nameserverip domain.com
    Multiple A-Records:
    Make sure you do not have multiple A-records.

    Redirects:
    Make sure something in the site itself is not redirecting.
     
  3. beservers

    beservers Registered

    Joined:
    Sep 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for teh reply.

    Checked everything and no issues on dns site.
    But the problem is still there.
    This morning everything was ok, 2 hours later the domain svagroup.org was unavailable. If I ping the domain it goes to the old ip of the former host, en if I do a nslookup it's pointing correct.

    Can't follow here.

    But it seems only visitors of 1 main ISP in Belgium have this problem.
    It's now 6 days after the transfer.
     
  4. ChrisRHS

    ChrisRHS Well-Known Member

    Joined:
    Jul 12, 2006
    Messages:
    292
    Likes Received:
    5
    Trophy Points:
    18
    Hello there,

    The only thing that I see is that you do not have any glue for your dns servers. Make sure they are listed in your zone file as your name servers.

    Chris
     
  5. beservers

    beservers Registered

    Joined:
    Sep 12, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    There are glue record on my nameservers ns1.beservers.be ...

    Other online check indicates it's ok:

    Name Server Count You have 3 name servers. Pass
    Name Server Glue Server also returned 'glue' records:
    62.182.57.115 [BE] (ns1.beservers.be)
    62.182.57.116 [BE] (ns2.beservers.be)
    213.163.66.231 [Unknown] (ns3.beservers.be) Pass
     
Loading...

Share This Page