The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain literal

Discussion in 'General Discussion' started by Skin, Jun 6, 2013.

  1. Skin

    Skin Well-Known Member

    Joined:
    Feb 3, 2006
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Italy
    Hello I'm trying to allow domain literals, but I have some problems:

    In my /etc/exim.conf I can see:
    Code:
    # If you want to accept mail addressed to your host's literal IP address, for
    # example, mail addressed to "user@[111.111.111.111]", then uncomment the
    # following line, or supply the literal domain(s) as part of "local_domains"
    # above.
    
    # local_domains_include_host_literals
    if I uncomment # local_domains_include_host_literals exim won't restart so I commented the line again.

    Have you any suggestions?

    Thanks
    Alessio
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can browse to "WHM Home » Service Configuration » Exim Configuration Manager » Advanced Editor". Scroll down until you see "Add additional configuration setting" (it's just above Section: BEGINACL"). Then, select the following option from the drop-down menu:

    "allow_domain_literals"

    Here is it's description:

    If this option is set, the RFC 2822 domain literal format is permitted in email addresses. The option is not set by default, because the domain literal format is not normally required these days, and few people know about it. It has, however, been exploited by mail abusers. Unfortunately, it seems that some DNS black list maintainers are using this format to report black listing to postmasters. If you want to accept messages addressed to your hosts by IP address, you need to set allow_domain_literals true, and also to add @[] to the list of local domains (defined in the named domain list local_domains in the default configuration). This “magic string” matches the domain literal form of all the local host’s IP addresses.

    Thus, after setting the value to true and saving, you have to add the IP addresses to the /etc/localdomains file in this format:

    [IP]

    Thank you.
     
  3. Skin

    Skin Well-Known Member

    Joined:
    Feb 3, 2006
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Italy
    Hello,
    I don't have any /etc/localdomains, should I create it?

    Thanks for your reply
    Alessio
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, you should create that file if it does not exist. However, it should already exist on any server where you have installed cPanel and created accounts.

    Thank you.
     
  5. Skin

    Skin Well-Known Member

    Joined:
    Feb 3, 2006
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Italy
    I'm going to create it... but it is strange: I'm using cpanel and I've some accounts on this vps.

    Thanks
    Alessio
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Are you sure you are logged in as root and spelling it correctly? EX:

    Code:
    root@vps [~]# ls /etc/localdomains
    /etc/localdomains
    Thank you.
     
  7. Skin

    Skin Well-Known Member

    Joined:
    Feb 3, 2006
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Italy
    Hello, probably I wasn't spelling correctly: ls /etc/localdomains returns /etc/localdomains

    Thanks very much
     
Loading...

Share This Page