The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain literals, email not delivered, frozen

Discussion in 'E-mail Discussions' started by gpilot, Jun 3, 2009.

  1. gpilot

    gpilot Member

    Joined:
    Nov 26, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Greetings all:

    Can anyone help with this? Am running Centos 4.7, Cpanel 11.24.4, Exim v4 with Chirpy's csf and lfd installed.

    We are going to migrate to a new server. After transferring all the accounts to the new server, but before changing the DNS entries which point to the old server, I would like to send emails to users on the new server in the format "userid"@[206.XXX.XXX.XXX] where 206.XXX.XXX.XXX is an IP on the _new_ server. This is the "domain literal" format.

    Without changes to exim.conf, the emails are rejected "domain literals not allowed" in the message from the server at SMTP time.

    I tried modifying exim.conf by uncommenting "local_domains_include_host_literals" as sugested in the file:

    # If you want to accept mail addressed to your host's literal IP address, for
    # example, mail addressed to "user@[111.111.111.111]", then uncomment the
    # following line, or supply the literal domain(s) as part of "local_domains"
    # above.

    local_domains_include_host_literals

    but upon restarting Exim I would get a "Exim configuration error" and the service would not start.

    Chirpy's suggestion is adding the line:
    "allow_domain_literals" to the first open textbox in Cpanel advanced conf. editor. He also suggested adding the IP used in the address field to the etc/localdomains file in the format [xxx.xxx.xxx.xxx], brackets included.

    The result is that there are no more bounce messages, however the emails are not being delivered. Each account on the server has a dedicated IP. The exim maillog indicates the email is "frozen".

    2009-06-03 20:06:38 1MC2Ll-00017v-RZ <= gregpilot@domain1.com H=dblt-216-227-20-222.gtcom.net ([127.0.0.1]) [216.227.20.222] P=esmtpa A=fixed_login:gregpilot@domain1.com S=632 id=20090603200615.796F.1CEF4671@domain1.com T="litts"
    2009-06-03 20:06:38 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1MC2Ll-00017v-RZ
    2009-06-03 20:06:38 1MC2Ll-00017v-RZ remote host address is the local host: [206.222.20.XXX]
    2009-06-03 20:06:38 1MC2Ll-00017v-RZ == gregpilot@[206.222.20.XXX] R=literal defer (-1): remote host address is the local host
    2009-06-03 20:06:38 1MC2Ll-00017v-RZ Frozen​

    This happens whether I use an external email acct to send or if I send from the same account on the server.

    There was another post somewhere which suggested adding the "@[] as a line in etc/localdomains however this does not seem to change anything. I have also tried adding the IP in the address to the etc/localdomains (within [] without success.

    Exim v3 did not have this problem.

    Help!! Thanks!
     
    #1 gpilot, Jun 3, 2009
    Last edited: Jun 4, 2009
Loading...

Share This Page