The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain mail problem

Discussion in 'E-mail Discussions' started by Trevs, Jan 1, 2006.

  1. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    On my server i have a problem with a domain recieving mail, It just builds up in the que and when i try and deliever it i keep getting this error:

    Code:
    LOG: MAIN
    lowest numbered MX record points to local host: hugotonhosting.com
    LOG: MAIN
    == admin@hugotonhosting.com R=lookuphost defer (-1): lowest numbered MX record points to local host
    LOG: MAIN
    <= <> R=1EsuYT-0008VC-4v U=mailnull P=local S=1207
    
    I have looked on dnsreport.com and the prefence is set to 10 for the mx record.

    The domain is not in etc/localdomains. Should i add the domain myself and is there other files i should check aswel?

    Trev
     
  2. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Yes you should add it and make sure all local domains you are hosting are in this file also.

    After adding the domain come back with any other errors you receive.

    Just to add I checked your dnsreport and you jave some red patches that need addressing. The main one is ask your data center to instigate the reverse dns (PTR) as this can course some emails to bounce.

    Fail: Reverse DNS entries for MX records


    :)
     
    #2 Izzee, Jan 1, 2006
    Last edited: Jan 1, 2006
  3. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks Izzee! The mail is working fine now :), and thankyou very much for telling me about the Reverse DNS entries for MX records as iv always been woundering why my customers carnt email people on aol ect.
     
  4. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Your welcome and I am glad it fixed things for you. :D

    Just one more red fail to remove and that is the postmaster and abuse addresses. Do you know how to do that? I have just fixed the same problem on my domains after some in depth exim configuration issues. It is now working again.

    :)
     
  5. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I believe PTR records have been added and take up to 8 hours to propagate. hopefully that will sort that. If not i will request some morre help with it.

    thanks Izzee
     
  6. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    No the PTR won't fix that so here's the fix which will take effect as soon as you implement it.

    1. Create a file called /etc/myaliases with these 2 lines in it:

    postmaster: root
    abuse: root


    2. In the WHM > Exim Configuration Editor > Advanced scroll down to the
    section "DIRECTORS CONFIGURATION" and in the first textbox
    of that section put:

    mysystem_aliases:
    driver = redirect
    allow_defer
    allow_fail
    data = ${lookup{$local_part}lsearch{/etc/myaliases}}
    file_transport = address_file
    pipe_transport = address_pipe
    retry_use_local_part


    Scroll down to the bottom and click on Save
    You'll then have a server-wide postmaster and abuse address
    that won't be interefered with by users having :fail: default addresses.

    This was posted in these forums some time back for the benefit of all members.

    :)
     
    #6 Izzee, Jan 1, 2006
    Last edited: Jan 2, 2006
  7. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks Izzee Its all working now :).

    You have been a great help!!
     
  8. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    pop3 (outlook express)

    Hi guys, i am still having mail problems but now with pop3. I do "service xinetd restart" and it works for about 5mins then it wont work again :mad: .

    Anybody got any ideas on the problem?

    Trev
     
    #8 Trevs, Jan 4, 2006
    Last edited: Jan 4, 2006
  9. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    #9 Izzee, Jan 4, 2006
    Last edited: Jan 4, 2006
  10. pejvak

    pejvak Registered

    Joined:
    Jan 4, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    i have cPanel problem

    I have no idea who to turn to, i have created e-mail for my website in cPanel
    when ever i send e-mail to it, i bounces back with this message:
    This is an automatically generated Delivery Status Notification

    Delivery to the following recipient failed permanently:
    pls help?
    i have sent a few e mails to my host for help, have not received any?

    Pejvak :rolleyes: :confused: :(
     
    #10 pejvak, Jan 4, 2006
    Last edited: Jan 4, 2006
  11. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Your post is not related to this thread therefore you should open a new thread and post your question with much more detail of the error to obtain any help members might volunteer to give you.

    This is not a support forum for hosted end users of cPanel. It is for cPanel licence owners to seek advice and help from other cPanel licence holders.

    You should always seek support from your hosting provider and provide as much detail as is required. If they won't or can't help you then it would be time to jump ship.

    Also read the forum sticky posts and learn how to use the search facility. It is your best friend.

    :)
     
  12. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  13. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Re check all the steps in my post above in case they have been 'cPanel automagically' replaced or removed.

    :)
     
  14. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks for the advice izzee,

    Is there a way to make the etc/localdomains file as it contains nothing. I have tryed /scripts/mailperm as i saw in another post but it did nothing.

    Thankyou!

    Trev
     
  15. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Try:
    /scripts/updateuserdomains
    /scripts/mailperm


    Then add any that are still missing using any text editor.

    Mine looks like this:

    [111.111.111.111]
    [111.111.111.112]
    userdomain.tld
    hostname.server.tld

    etc etc

    The top IPs are my ns1 and ns2.

    You could also try after the above:
    /scripts/upcp
    which has been know to fix a few things.

    Also make sure the permissions on /etc/localdomains is set to 0660 and owned by root group mail

    :)
     
    #15 Izzee, Jan 20, 2006
    Last edited: Jan 20, 2006
  16. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Im not sure how to do this, could you please tell me how i go about it. Also there was no ip in etc/localdomains as you showed in your example. Do i need to add the ips?
     
  17. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    Did the localdomains file get populated with the above commands or did you have to edit the file and fill in all the domains?

    chmod 0660 /etc/localdomains
    chown root:mail /etc/localdomains


    Should do the trick.

    This from my HelpFile db, source unknown but thanks to who ever it was plus it might help to explain the bracketed IPs for you:

    :)
     
    #17 Izzee, Jan 21, 2006
    Last edited: Jan 21, 2006
  18. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thankyou izzee it worked wounderfull!

    Trev
     
  19. Trevs

    Trevs Member

    Joined:
    Dec 11, 2005
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Im not having to much luck with the mail on my server :(, when i do a dnsreport on the mail i get:

    Code:
    Step 1:  Try connecting to the following mailserver:
             hugotonhosting.com. - 209.97.214.81
    
    Step 2:  If still unsuccessful, queue the E-mail for later delivery.
    

    The server is up and exim is running. Also it happening to every domain on my server.

    Thankyou for the help

    Trev
     
    #19 Trevs, Jan 22, 2006
    Last edited: Jan 22, 2006
  20. Izzee

    Izzee Well-Known Member

    Joined:
    Feb 6, 2004
    Messages:
    469
    Likes Received:
    0
    Trophy Points:
    16
    That's normal and nothing to worry about. Check my domains in my sig. at the dnsreport mail check to see that it also gives that message. Your main DNS report looks good also, great job.

    :)
     
Loading...

Share This Page