Domain Name Pointing to Wrong Account?

maysam

Member
Sep 30, 2018
11
0
1
palestine
cPanel Access Level
Root Administrator
hi all

we have made a lot of changes in our server to connect it under WAF device

but we face problems with SSL certificate and WAF with security team are working to solve it

my question is when i request certain site example1.com hosted on our server it automatic open site example2.com which is also hosted in the same server under another cpanel account !!!

why this be done ???

no redirects in both accounts

also when i use plain server ip it open the same site example2.com !!

what can i do to check the source of this issue??

note : the we have 20 accounts on this server just one redirect as i mention above
help me ASAP
thanks in advance
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,760
314
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Not enough details to know definitively, but this behavior can be explained if you are accessing using https and exmaple.com does not have any kind of ssl certificate installed. If there is no ssl certificate installed, it will go to the first site in the config that has one.

What you need to do is install an SSL certificate on example.com. It can even be self-signed or whatever, but it has to have one if they are sharing the same IP.
 

maysam

Member
Sep 30, 2018
11
0
1
palestine
cPanel Access Level
Root Administrator
Not enough details to know definitively, but this behavior can be explained if you are accessing using https and exmaple.com does not have any kind of ssl certificate installed. If there is no ssl certificate installed, it will go to the first site in the config that has one.

What you need to do is install an SSL certificate on example.com. It can even be self-signed or whatever, but it has to have one if they are sharing the same IP.
thank you for your reply

SSL is installed to the whm accounts through AutoSSL provided by WHM , so if i want to enable ssl to accounts i did from manage autossl and enable for all users


we still face problem with ssl certificate and fortiweb , we declare the main host ssl certificate on fortiweb so we can open whm and cpanel for main host in https and it is worked well but the accounts hosted on it didn't work well still we have to click proceed to unsafe site and some sites open after long long delay


beside the problem of two example.com i mentioned i checked autossl and it is enabled on both also when i browse to the server IP it open the link example2.com as i mentioned at first
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,760
314
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Just enabling autossl may not work, you said there was a waf involved and that may be preventing autossl from actually installing a certificate. Did you look to see if there was an actual certificate installed for, using your exmaple, example.com?
 

maysam

Member
Sep 30, 2018
11
0
1
palestine
cPanel Access Level
Root Administrator
Just enabling autossl may not work, you said there was a waf involved and that may be preventing autossl from actually installing a certificate. Did you look to see if there was an actual certificate installed for, using your exmaple, example.com?
yes both domains in AutoSSL manager said the ssl enabled
 

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,760
314
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
You should look in manage SSL certificates and see if there is actually an SSL installed on the domain. If there is not, manually run autossl on the user and check the logs and see what it says it should explain why its failing.
 

maysam

Member
Sep 30, 2018
11
0
1
palestine
cPanel Access Level
Root Administrator
You should look in manage SSL certificates and see if there is actually an SSL installed on the domain. If there is not, manually run autossl on the user and check the logs and see what it says it should explain why its failing.

thankyou for your reply

i run autossl from autossl manage for the user with problem and the result was :

Code:
 Checking websites for “web43” …
 10:32:06 PM Analyzing “lxxx.ps” …
 10:32:06 PM User-excluded domains: 4 (mail.lxxx.ps, webmail.lxxx.ps, cpanel.lxxx.ps, webdisk.lxxx.ps)
 ERROR TLS Status: Defective
 ERROR Defect: NO_SSL: No SSL certificate is installed.
 10:32:06 PM Performing DCV (Domain Control Validation) …
 10:32:30 PM WARN Local HTTP DCV error (lxxx.ps): “lxxx.ps” does not resolve to any IP addresses on the internet.
 10:33:06 PM WARN Local HTTP DCV error (www.lxxx.ps): “www.lxxx.ps” does not resolve to any IP addresses on the internet.
 10:33:30 PM ERROR Local DNS DCV error (lxxx.ps): The DNS query to “_cpanel-dcv-test-record.lxxx.ps” for the DCV challenge returned no “TXT” record that matches the value “_cpanel-dcv-test-record=DMUR1zx2pmJjtmc3f__IeHZ3VAurGaYccIwMF79FWatYwhil_cPj3q3wkiZaRkLS”.
 ERROR Local DNS DCV error (www.lxxx.ps): The DNS query to “_cpanel-dcv-test-record.lxxx.ps” for the DCV challenge returned no “TXT” record that matches the value “_cpanel-dcv-test-record=DMUR1zx2pmJjtmc3f__IeHZ3VAurGaYccIwMF79FWatYwhil_cPj3q3wkiZaRkLS”.
 10:33:30 PM Analyzing “lxxx.ps”’s DCV results …
 10:33:30 PM ERROR Impediment: TOTAL_DCV_FAILURE: Every domain failed DCV.
 10:33:30 PM The system has completed the AutoSSL check for “web43”.
i make sure that domain is registered and active

but still the ssl not installed on that domain

how can i solve the problem ?
 
Last edited by a moderator:

maysam

Member
Sep 30, 2018
11
0
1
palestine
cPanel Access Level
Root Administrator
Code:
Checking websites for “web217” …
12:38:33 PM Analyzing “xxx.xx.ps” …
12:38:33 PM ERROR TLS Status: Defective
ERROR Certificate expiry: 4/10/19, 12:00 AM UTC (1.4 days ago)
ERROR Defect: OPENSSL_VERIFY: The certificate chain failed OpenSSL’s verification (0:10:CERT_HAS_EXPIRED).
12:38:33 PM Performing DCV (Domain Control Validation) …
12:39:03 PM ERROR “xxx.xx.ps” is not a registered internet domain.
ERROR “www.xxx.xx.ps” is not a registered internet domain.
ERROR “mail.xxx.xx.ps” is not a registered internet domain.
ERROR “cpanel.xxx.xx.ps” is not a registered internet domain.
ERROR “webdisk.xxx.xx.ps” is not a registered internet domain.
ERROR “webmail.xxx.xx.ps” is not a registered internet domain.
12:39:03 PM Analyzing “xxx.xx.ps”’s DCV results …
12:39:03 PM ERROR Impediment: TOTAL_DCV_FAILURE: Every domain failed DCV.
12:39:03 PM The system has completed the AutoSSL check for “web217”.
why this issue appear ,,, alot of users when i check their ssl the result as abot ,what is DCV ? why the domain is not registered internet domain but it is registered and hosted ?
 
Last edited by a moderator:

GOT

Get Proactive!
PartnerNOC
Apr 8, 2003
1,760
314
363
Chesapeake, VA
cPanel Access Level
DataCenter Provider
Well according to the logs your server can not resolve the domain you are trying to get an SSL certificate installed on. That either means the DNS for this domain is broken or that there is something wrong with the resolvers.

In shell what is the result of the command

host domainforssl.com

What is in your /etc/resolv.conf

What is the output of the command

host domainforssl.com 8.8.8.8
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello @maysam,

Can you open a support ticket so we can take a closer look at your system to see why the AutoSSL domain validation process is failing? You can post the ticket number here after it's submitted and I'll link this thread to it.

Thank you.
 

maysam

Member
Sep 30, 2018
11
0
1
palestine
cPanel Access Level
Root Administrator
Well according to the logs your server can not resolve the domain you are trying to get an SSL certificate installed on. That either means the DNS for this domain is broken or that there is something wrong with the resolvers.

In shell what is the result of the command

host domainforssl.com

What is in your /etc/resolv.conf

What is the output of the command

host domainforssl.com 8.8.8.8

thank you for your help

i excute the commands and the results seems good
please see attached


regards
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
i open ticket
Ticket Created at buycpanel #218700
Hello @maysam,

It looks like the ticket was opened directly with your license provider. Can you let us know how the support request turns out?

Thank you.