Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain redirecting issue

Discussion in 'Bind / DNS / Nameserver Issues' started by recraig, Mar 25, 2017.

  1. recraig

    recraig Registered

    Joined:
    Mar 25, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ukraine
    cPanel Access Level:
    Root Administrator
    First, here is my system info
    • /etc/redhat-release:CentOS Linux release 7.3.1611 (Core)
    • /usr/local/cpanel/version:11.62.0.17
    • /var/cpanel/envtype:standard
    • CPANEL=release
    • Server version: Apache/2.4.25 (cPanel)
    • Server built: Mar 20 2017 15:23:03
    • ea-php-cli Copyright 2016 cPanel, Inc.
    • PHP 5.6.30 (cli) (built: Mar 22 2017 18:13:01)
    • Copyright (c) 1997-2016 The PHP Group
    • Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    • mysql Ver 14.14 Distrib 5.6.35, for Linux (x86_64) using EditLine wrapper
    This is a dedicated server with Hertzner's auction servers with multiple IP's. I have root administrator rights. The IP for this domain is 136.243.xx.xx and is owned by the reseller. I have other domains on this IP that are working fine, but none of them are registered with the same registrar as the domain exhibiting the behavior.

    I have a WHM account with the domain example.com (don't laugh since I cannot fix my WHM problem and my domain says "brightest" ;-) ). The non-www version is redirecting to example2.com, the www version to example.com and never resolves. I think I remember mistyping the name as example2.com at one time in the process of doing something to set it up, but after terminating the account in WHM there should be no records left, right?
    • I have consulted with the registrar and they confirm it is a server setting issue.
    • I have consulted with the data center and they verify the IP is reachable without problems, which was obvious since the other domains on the IP are reachable... Hertzner techs are rather idiots and very VERY rude.
    • I have deleted this account and recreated it. No dice.
    • I have cleared the registrar's data down to the metal of just an A-record and the registrar's default nameservers. No dice. Nada. Nothing. Same results.
    • I have gone through every file in /etc and searched for example2 and there are no references to it.
    • I have verified the results on my phone which runs through my phone service provider, not wifi connection and on my laptop on the home internet connection, a different provider from my phone service. Same results.
    • I verified in httpd.conf no reference to example2
    • There are no .htaccess files in the domain's root directory. It is also a fresh account creation, so no straggling files are garbage.

    Current behavior:
    Code:
    example.com --> example2.com
    http://www.example.com --> example.com
    
    Desired behavior:
    Code:
    example.com --> example.com
    http://www.example.com --> example.com
     
    #1 recraig, Mar 25, 2017
    Last edited by a moderator: Mar 25, 2017
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,769
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I am seeing the desired behavior here as you expected.
     
Loading...

Share This Page