The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain redirecting to /cgi-sys/defaultwebpage.cgi

Discussion in 'General Discussion' started by section31, Dec 1, 2009.

  1. robhf

    robhf Registered

    Joined:
    Dec 20, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I think this is a cache thing. I just did the last part of Eric's fix and it worked fine without all the preceding difficult stuff). So this is the bit that worked "If not, try going directly to a page on your server (i.e. index.html for example), and that will usually force your browser to refresh the content its pulling from the site."
     
  2. sp1k3ster

    sp1k3ster Registered

    Joined:
    Jun 29, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    The issue for me was IPv6 related. Here is the ticket response I got from cPanel:

    This appears to be an issue with IPv6. Since the system has an IPv6 address assigned to it Apache will listen for incoming IPv6 connections. However, since none of the sites or accounts are configured to use IPv6 Apache will just route the request to the default file - /cgi-sys/defaultwebpage.cgi. I tested this further by disabling Apache from listening on IPv6 by commenting out the following from the /usr/local/apache/conf/httpd.conf file:

    Listen[::]:80

    I then restarted Apache, and viewed the page in my web browser as well as through a few proxy connections and I no longer experienced the default page issue. One piece of evidence that brought IPv6 to my attention was this message in the Apache error log:

    [Sun Jun 29 09:03:43 2014] [error] [client 2607:5300:100::502] File does not exist: /usr/local/apache/htdocs/DOMAIN-DIRECTORY

    As you can see the client appears to be accessing or trying to access the site using an IPv6 address and as well we can see it's being directed into the /usr/local/apache/htdocs folder.

    The solution here, will be to either comment out the Listen directive in the Apache configuration for IPv6 or setup IPv6 for the accounts on the system. Setting this up can be done from within WHM >> IP Functions >> IPv6 Ranges and WHM >> IP Functions >> Enable IPv6. If you'd rather stick with IPv4 now, which is what most people are doing I would recommend just commenting out the Listen directive in the httpd.conf file and restarting Apache for the change to take effect.

    If you have any other questions or issues please let me know.
     
  3. catwalkghost

    catwalkghost Registered

    Joined:
    Jun 3, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London
    cPanel Access Level:
    Website Owner
    Having the issue after rebuilding with EasyApache. Everything was running fine prior to this.

    Tried /scripts/rebuildhttpdconf with no luck

    No changes to the exhaustive options were made
     
    #83 catwalkghost, Jun 3, 2015
    Last edited by a moderator: Jun 3, 2015
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    29,075
    Likes Received:
    509
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Are any of the previous posts to this thread helpful? If not, please open a support ticket and post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  5. catwalkghost

    catwalkghost Registered

    Joined:
    Jun 3, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London
    cPanel Access Level:
    Website Owner
    Hi Michael,

    Thanks for getting back to me. Unfortunately, the solutions mentioned in this thread were not helpful in our situation and I had to rebuild the server from a back up.
     
Loading...

Share This Page