The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

domain transfer screwed up email system

Discussion in 'E-mail Discussions' started by abubin, Jun 23, 2005.

  1. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    I have 2 server, old server running ensim and new server running cpanel.

    I am migrating sites from ensim to cpanel.

    I used the script provided by cpanel to migrate the sites. enXim option.

    So, I migrated site ddd.com to cpanel. But there are a lot of stuff to fix with the migration such as user's emails and quota and database re-direction. So, ddd.com would still go to ensim while i make sure ddd.com at cpanel is working fine. I give ddd.com at cpanel an IP which means I can access that IP to verify ddd.com in cpanel.

    But now, the problem is, when I try sending email from zzz.com which is located in cpanel, to ddd.com, cpanel server would send it to ddd.com locally instead of actually sending it to ensim server.

    So I changed ddd.com in cpanel to ddd11.com to make cpanel forget that ddd.com ever existed in it and that mails from zzz.com will actually go to ddd.com. But cpanel do not want to forget about ddd.com. Still thinking ddd.com reside in cpanel. How do I do make cpanel forget that ddd.com ever existed in it like before?

    I already tried restarting apache, bind and exim. Wouldn't help...

    Please help!!

    Thanks in advance.
     
  2. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Here is what i get when i try to send mails from zzz.com to ddd.com using squirrelmail at zzz.com :

    Requested action not taken: mailbox unavailable
    Server replied: 550 "The recipient cannot be verified. Please check all recipients of this
    message to verify they are valid."
     
  3. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    What about the MX entry....it is pointed to your ensim server or cpanel server??
     
  4. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    I am using webhost's DNS servers. Therefore, MX entry should have been the same. I checked MX entries in the cpanel and it's pointed to the old ensim server.

    Code:
    root@cpanel [~]# dig @cpanel.domain.net ensim.com MX
    
    ; <<>> DiG 9.2.4 <<>> @cpanel.domain.net ensim.com MX
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42102
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;ensim.com.                      IN      MX
    
    ;; ANSWER SECTION:
    ensim.com.               28000   IN      MX      10 mail.ensim.com.
    
    ;; AUTHORITY SECTION:
    ensim.com.               28000   IN      NS      ns1.rackshack.net.
    ensim.com.               28000   IN      NS      ns2.rackshack.net.
    
    ;; ADDITIONAL SECTION:
    mail.ensim.com.          28000   IN      A       216.12.213.999 --=> correct ensim server IP
    ns1.rackshack.net.      172800  IN      A       207.218.223.132
    ns2.rackshack.net.      172800  IN      A       207.218.223.162
    
    ;; Query time: 229 msec
    ;; SERVER: 67.15.48.12#53(cpanel.domain.net)
    ;; WHEN: Thu Jun 23 20:31:06 2005
    ;; MSG SIZE  rcvd: 144
    
     
  5. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    I have also tried deleting the whole account on cpanel. Once the account has been removed, emails are still not sent out correctly.

    ddd.com still refuse to go out of the cpanel server...
     
  6. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    found the problem!!! thanks to the tech support who helped me!! :P

    edit /etc/localdomains, remove the perky domain from this file. service named restart and all is well...
     
Loading...

Share This Page