Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain used only for email showing SSL error in Apache Log

Discussion in 'Security' started by mikefromnz, Mar 11, 2017.

Tags:
  1. mikefromnz

    mikefromnz Active Member

    Joined:
    Feb 9, 2017
    Messages:
    28
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    New Zealand
    cPanel Access Level:
    Root Administrator
    Hi guys,

    I have a customer who is hosting just their email with us, their DNS is pointing to my server, and they use mail.theirdomain.com to access, all is working well.

    I disabled AutoSSL for their domain but I see many entries in the Apache log like below

    [Sat Mar 11 23:15:28.250729 2017] [ssl:warn] [pid 15997:tid 139844625623008] AH01909: theirdomain.com:443:0 server certificate does NOT include an ID which matches the server name

    I am assuming this is because the DNS A record is pointing to their actual webhost so when Apache checks, it's not seeing the correct SSL?

    How do I fix this
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Is the website content handled on another server? If so, you can update the "A" record to point to the IP address where the content is hosted. Otherwise, you could enable the AutoSSL feature, allow it to install a valid SSL certificate on the domain name, and then upload a placeholder page to the website to note it's not active.

    Thank you.
     
Loading...

Share This Page