The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Domain Validation Error on AutoSSL

Discussion in 'Security' started by interactivegm, Aug 19, 2016.

Tags:
  1. interactivegm

    interactivegm Registered

    Joined:
    Dec 12, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iasi, Romania
    Hi Guys
    Activated AutoSSL on one of our servers but when i try to check for a domain i am getting the below error. Any suggestions?
    Code:
    
    Log for the AutoSSL run for “hostingaccountname”: Friday, August 19, 2016 6:55:31 PM GMT+0100 (Let’s Encrypt™)
    6:55:31 PM This system has AutoSSL set to use “Let’s Encrypt™”.
    6:55:31 PM Checking websites for “hostingaccountname” …
    6:55:31 PM The website “hostingaccountname.com”, owned by “hostingaccountname”, has no SSL certificate. AutoSSL will attempt to obtain a new certificate and install it.
    6:55:31 PM WARN The domain “hostingaccountname.com” has failed domain control validation (The system failed to fetch the <abbr title="Domain Control Validation">DCV</abbr> file at “<a href="http://hostingaccountname.com/13863.BIN_AUTOSSL_CHECK_PL__.J62UtzQHb7btcnoy.tmp">http://hostingaccountname.com/13863.BIN_AUTOSSL_CHECK_PL__.J62UtzQHb7btcnoy.tmp</a>” because of an error: The system failed to send an <abbr title="Hypertext Transfer Protocol">HTTP</abbr> “GET” request to “http://hostingaccountname.com/13863.BIN_AUTOSSL_CHECK_PL__.J62UtzQHb7btcnoy.tmp” because of an error: SSL connection failed for hostingaccountname.com: SSL connect attempt failed error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol .). at bin/autossl_check.pl line 449.
    6:55:31 PM WARN The domain “www.hostingaccountname.com” has failed domain control validation (The system failed to fetch the <abbr title="Domain Control Validation">DCV</abbr> file at “<a href="http://www.hostingaccountnamecom/13863.BIN_AUTOSSL_CHECK_PL__.RPxfm08njPRoUeBA.tmp">http://www.hostingaccountname.com/13863.BIN_AUTOSSL_CHECK_PL__.RPxfm08njPRoUeBA.tmp</a>” because of an error: The system failed to send an <abbr title="Hypertext Transfer Protocol">HTTP</abbr> “GET” request to “http://www.hostingaccountname.com/13863.BIN_AUTOSSL_CHECK_PL__.RPxfm08njPRoUeBA.tmp” because of an error: SSL connection failed for www.hostingaccountname.com: SSL connect attempt failed error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol .). at bin/autossl_check.pl line 449.
    6:55:31 PM The system has completed the AutoSSL check for “hostingaccountname”.
    6:55:31 PM The system has finished checking 1 user.
    
    
     
    #1 interactivegm, Aug 19, 2016
    Last edited by a moderator: Aug 22, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    The following thread offers some troubleshooting steps to use when a certificate isn't successfully generated:

    cPanel & WHM’s AutoSSL/SSL ordering process

    Could you review this thread and post the output from the "curl" command if the issue continues?

    Thank you.
     
  3. martin MHC

    martin MHC Member

    Joined:
    Sep 14, 2016
    Messages:
    15
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hello
    I have the same issue. I have checked the IP addresses of Comodo and they're not blocked by my WHM.

    The text file exists on my public_html/ account folder.

    I have a htaccess which redirects to secure connection and redirects to www.domain so http://domain.co.uk --> https://www.domain.co.uk which I have temporarily disabled so comodo/Curl should get through.

    I have just run the Curl request from the linked topic, and it returns the correct data (the contents of the .txt file).

    What else can be causing the same error logs as detailed by
    interactivegm?

    Cheers
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello @martin MHC,

    Could you open a support ticket using the link in my signature so we can take a closer look and see what's happening? You can post the ticket number here and we will update this thread with the outcome.

    Thank you.
     
  5. martin MHC

    martin MHC Member

    Joined:
    Sep 14, 2016
    Messages:
    15
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hi Michael,
    Thanks for getting back to me, I have set a support ticket : 7866267


    Cheeers
    Martin
     
  6. martin MHC

    martin MHC Member

    Joined:
    Sep 14, 2016
    Messages:
    15
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    The issue was resolved by upgrading to WHM version 60
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I'm happy to see the addition of .htaccess rule exclusions during the AutoSSL validation process in cPanel version 60 addressed the issue. Thank you for updating us with the outcome.
     
Loading...

Share This Page