SOLVED "Domains" interface issue

PeteS

Well-Known Member
Jun 8, 2017
303
66
78
Oregon
cPanel Access Level
Root Administrator
I'm going to piggy-back this on here, since it related to the new Domains interface (split it off if you think it needs to be/is a valid issue). The following relates only to the new interface...

Yesterday I couldn't create a subdomain, and got "Error: You must specify a subdomain." (obviously, I did set a subdomain!) if I unchecked the box "Share document root (/home/ ..." If I left it checked it would *not* create an alias domain as expected, but instead would create a subdomain.

Today I discovered that it I altered the text in home directory box, changing, then changing back to the original that matched the subdomain above that it had rejected, it would work. Next I tried it without doing that and subdomain creation worked as expected, AND alias creation (box checked) worked as well.

A- I am *not* crazy
B- I had reloaded the page many times
C- I was using the same subdomains to test with
D- I'm wondering if there was a change made recently, that might have rolled out for me last night, addressing this odd behavior

I cannot recreate the issue now, but it did happen. I Googled: cpanel "Error: You must specify a subdomain." and got zip. So think I'm the first to see "Error: You must specify a subdomain." What actually should trigger that message?

Also, on this page: Domains | cPanel & WHM Documentation why are the sections Change Primary Domain an List Accounts there? There aren't in that interface?

-Pete
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,360
1,632
363
cPanel Access Level
Root Administrator
Hey hey! Here's the process I took on my end:

-Go to cPanel >> Domains
-Click "Create a new domain"
-enter a subdomain

That worked well. I then did this for an alias:

-Go to cPanel >> Domains
-Click "Create a new domain"
-enter a subdomain
-ensured that "Share document root (/home/username/public_html) with “domain.com” was selected

and that worked well also.

This is all on the latest 102.0.15. If you have a machine you can reliably reproduce this on, we'd like to see a ticket to do some testing.