Domains not logging to domlogs when using cloudflare

Zishan

Well-Known Member
Aug 6, 2005
107
1
168
We have a customer who complained that awstats (and the domlogs) stopped logging for all their domains. Checking the domains, all of them are using cloudflare. For testing, we had the user pause cloudflare on and the domlogs started to pick up the traffic right away, On enabling Cloudflare, domlogs stopped logging the website traffic. I researched on it and there are several articles even on cloudflare site on how to let real visitors IPs logged instead of CloudFlare Ips so that means the domlogs should be populated if CLoudFlare enabled even just logging CloudFlare Ips but this is not happening here.

Any ideas what can be checked?
 

Zishan

Well-Known Member
Aug 6, 2005
107
1
168
Many of the domains should be using CloudFlare. So anyone using CloudFlare experienced this behavior ? Just trying to identify whether its an expected behavior or others are getting visitors traffic logged in domlogs ?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
Hello,

Can you please provide me with the version of cPanel & WHM you are currently running? There was an issue with this behavior at one point but it was resolved in v88.0.10. The related thread can be found here: SOLVED - [EA-9123] Only IPv6 logs show to access log
 

Zishan

Well-Known Member
Aug 6, 2005
107
1
168
Hello Lauren,

I appreciate your response. The server is running 11.86.0.24. I have checked the mentioned thread but with CloudFlare enabled, we are not seeing any traffic logs added not even IPv6 traffic logs.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
Well, that original issue was a result of stopping logging for proxied requests. So I believe it's still related. What's the output of the following?

Code:
grep ea-apache24-config /var/log/yum.log*
When did the logging stop?