cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,263
313
Houston
You're referencing multiple different domains there.

  • In the Domains Interface:
DomainDocument RootRedirection
domain.crypto.tk /public_html/domain.crypto.tk Not Redirected
domain.gq
/public_html/Not Redirected

  • In Addon Domains:
DomainDocument RootRedirection
domain.crypto.tk domain.crypto.tkdomain.gq

  • In Subdomains:
DomainDocument RootRedirection
domain.crypto.tk.domain.gqpublic_html/domain.crypto.tk Not Redirected

It looks like here that the domain in subdomains is not the same as the others (without being able to see the domain names)

The only redirection that isn't really showing is the one in addon domains compared with the one in domains correct?
 

cronnin

Registered
Feb 23, 2020
2
0
1
Belgrade
cPanel Access Level
Website Owner
Those are two different domains. I first had (not real names):

domain.gk as main domain, then tried to add
domain2.tk to point to same website

Since there is no Parked/Aliases on my hosts's cPanel, I've made a domain2.tk addon domain, and it seems cPanel had created a subdomain domain2.tk.domain.gk with a corresponding subfolder 'domain2.tk' in public_html.

Then, in the same Addon panel I went to Manage Redirections, and pointed the new addon website to main's URL:

Domain “domain2.tk” redirects to:

1. Note that I'm new to cPanel and DNS, so I may be doing something not usual or appropriate.
2. I still don't understand why I don't see that redirect anywhere else than in Addon panel. Maybe it's a different kind of redirect than subdomain redirect, etc?
3. One other thing. When I try to add the second domain I get an error mistake:
Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server.

a. Thing is I have an exactly same nameserver settings for both domains.
b. I resolve it in WHM by allowing the remote domains in WHM , then add the domain, then turn off remote domains in WHM, and it still works. Why?!
 
Last edited by a moderator: