sergios

Member
Apr 11, 2018
19
1
3
Brasil
cPanel Access Level
Root Administrator
Em alguns domínios que hospedo, alguns consigo entrar no CPanel utilizando dominio.com.br/cpanel, e em outros só entro no CPanel através da porta https://dominio2.com.br:2083
Nestes que só entro utilizando a porta, quando digito dominio2.com.br/cpanel, ele redireciona para o hostname do servidor, ficando https://hostname.com.br:2083. Mas não entra no Cpanel.
Não vejo erro no log.
Onde verifico esse problema?
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @sergios,

This relates to the following option under the Redirection tab in WHM >> Tweak Settings:

Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS”

Here's the description of this option so you are aware of the change that will occur by turning it off:

When a user visits /cpanel, /webmail, /whm, or visits other URLs that redirect to a cPanel service, the system will redirect to an SSL URL for the closest matched domain that the system has a valid certificate. If you disable this option, the system will redirect to the equivalent URL that they visited based on the original request made via HTTPS or HTTP. This option also controls how the system will redirect unencrypted cPanel, Webmail, WHM, and DAV requests to the best matched certificate for the domain when “Require SSL” is enabled. When enabled, it will redirect closest matched domain that the system has a valid certificate for. When it is disabled, it will simply redirect equivalent HTTPS URL.
Thus, the best approach to solve this issue is to ensure a signed SSL certificate is installed for the individual domain name. You can ensure a free signed SSL certificate is installed on the domain name via the AutoSSL feature:

Manage AutoSSL - Version 74 Documentation - cPanel Documentation

Otherwise, you'd need to disable the option noted at the top of this post and then set "SSL redirect destination" to "Original Domain Name".

Thank you.

Translation:

Olá @sergios

Isso se relaciona com a seguinte opção na guia Redirecionamento no WHM >> Ajustes Tweak:

Escolha o domínio correspondente mais próximo para o qual o sistema possui um certificado válido ao redirecionar de URLs não SSL para SSL. Anteriormente conhecido como "Sempre redirecionar para SSL / TLS"

Aqui está a descrição dessa opção para que você esteja ciente da alteração que ocorrerá ao desativá-la:

Quando um usuário visita / cpanel, / webmail, / whm ou visita outras URLs que redirecionam para um serviço cPanel, o sistema redirecionará para uma URL SSL para o domínio correspondente mais próximo em que o sistema tenha um certificado válido. Se você desativar essa opção, o sistema redirecionará para o URL equivalente que eles visitaram com base na solicitação original feita via HTTPS ou HTTP. Esta opção também controla como o sistema redirecionará os pedidos cPanel, Webmail, WHM e DAV não criptografados para o melhor certificado correspondente para o domínio quando a opção "Requerer SSL" estiver ativada. Quando ativado, ele redirecionará o domínio correspondente mais próximo ao qual o sistema possui um certificado válido. Quando estiver desativado, ele simplesmente redirecionará o URL HTTPS equivalente.
Assim, a melhor abordagem para resolver esse problema é garantir que um certificado SSL assinado seja instalado para o nome de domínio individual. Você pode garantir que um certificado SSL assinado e gratuito esteja instalado no nome do domínio por meio do recurso AutoSSL:

Manage AutoSSL - Version 74 Documentation - cPanel Documentation

Caso contrário, você precisará desativar a opção indicada na parte superior desta postagem e definir "Destino de redirecionamento de SSL" como "Nome de domínio original".

Obrigado.