Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Domlogs Processing Buffer Location

Discussion in 'General Discussion' started by Bob1965, Aug 30, 2018.

  1. Bob1965

    Bob1965 Member

    Joined:
    Aug 30, 2018
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Germany
    cPanel Access Level:
    Root Administrator
    Hi,

    I have an issue on a VPS that I would like to resolve for a very low traffic website.
    When tailing a low traffic website in SSH, the domlog does not update in real time, it waits until 17 files are accessed then it processes it. I guess this would be called a buffer and I would like to know where this setting is so I can lower it.

    Here is the VPS version info:

    /etc/redhat-release:CentOS Linux release 7.5.1804 (Core)
    /usr/local/cpanel/version:11.74.0.6
    /var/cpanel/envtype:kvm
    CPANEL=release

    Thanks for the information in advance.

    Regards,
    Bob
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    473
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Bob1965

    Can you tell me where you're tailing them from? The domlogs at
    Code:
    /etc/apache2/logs/domlogs/domain.tld
    should be updating in real time.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Bob1965

    Bob1965 Member

    Joined:
    Aug 30, 2018
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Germany
    cPanel Access Level:
    Root Administrator
    Hello Lauren,

    tail -f /usr/local/apache/domlogs/website.com

    I have checked every website on the server and it only updates when 17 files have been accessed.
    If no one visits the website for even 3 days, I do not see any updates to the file. But if I pull up a file I can see it in the apache status in WHM. If I pull up 17 different files or even refresh 17 times, the tail will all of a sudden post all 17 at once. So there must be some buffer configuration somewhere. lso to be noted, I have Piped Log Configuration enabled. Maybe I should disable this?

    Regards,
    Bob
     
    #3 Bob1965, Aug 31, 2018
    Last edited by a moderator: Aug 31, 2018
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    473
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Bob1965


    I believe piped logging will do something like this though it's not exactly 17 files as the settings. Information on this can be found here: The splitlogs Binary - Version 74 Documentation - cPanel Documentation

    I don't believe there's a way to modify the behavior per say though. You could try manipulating maxopen:

    Example:
    Code:
    /usr/local/cpanel/bin/splitlogs ‑‑maxopen=20000
    Otherwise, you might try with piped logging disabled.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 cPanelLauren, Aug 31, 2018
    Last edited: Aug 31, 2018
    Bob1965 likes this.
  5. Bob1965

    Bob1965 Member

    Joined:
    Aug 30, 2018
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    3
    Location:
    Germany
    cPanel Access Level:
    Root Administrator
    turning off the piped logging worked :)
     
    cPanelLauren likes this.
  6. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,124
    Likes Received:
    473
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @Bob1965

    I am glad to see that resolved the issue. Just keep in mind that piped logging does have some resource benefits and if you start seeing higher usage than normal attributed to Apache the disabling of piped logging is most likely the cause. You would most likely only notice this if you had a moderately busy server.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Bob1965 likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice