The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dont have permmision to edit php.ini

Discussion in 'General Discussion' started by vishwas, Mar 12, 2005.

  1. vishwas

    vishwas Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Front of PC
    Hello

    I dont have root access and i m trying to turn off some process via .htaccess but when i add those line i get 500 Internal server error.

    php_value magic_quotes_gpc 0
    php_value magic_quotes_runtime 0
    php_value magic_quotes_sybase 0

    And let me know how to turn off safe_more , registre_global off

    php ver.
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with Zend Extension Manager v1.0.0, Copyright (c) 2003, by Zend Technologies
    with Zend Optimizer v2.1.0, Copyright (c) 1998-2003, by Zend Technologies

    WHM 9.9.9 cPanel 9.9.9-S15
    RedHat Enterprise 3 i686 - WHM X v3.1.0


    Thank you in advance

    Regards
     
  2. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    Does the server run phpsuexec?

    If so , then you can't use php_value in .htaccess

    You need to create a file called php.ini and place it within each directory that you need to change options.

    All you need is the following

    php.ini

    register_globals = 0
    safe_mode = 0


    and any options as needed, same format as they appear in the servers main php.ini

    Your hosting company should be able to assist you further, if you need any help setting that up or your server isn't running phpsuexec.
     
    #2 DigitalN, Mar 13, 2005
    Last edited: Mar 13, 2005
  3. vishwas

    vishwas Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Front of PC
    yes phpsuexec is enabeld on server .

    and m using cpanel not ensim.

    Regards,
     
  4. vishwas

    vishwas Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Front of PC
    Thank you but that didnt work and i try to use like this and it worked

    register_globals = Off
    register_argc_argv = Off
    safe_mode = On
    magic_quotes_gpc = Off

    Cheers :rolleyes: ;)
     
Loading...

Share This Page