The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dovecot cannot be started, fails with no log

Discussion in 'E-mail Discussions' started by feanorknd, Oct 28, 2015.

  1. feanorknd

    feanorknd Member

    Joined:
    Sep 28, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hello:

    Suddenly, dovecot failed when saving changes at "service manager" at WHM... obviously, it is checked twice, to the monitor is sending me emails continuosly.

    At log /var/log/maillog, I only have this line:

    Nothing else...

    Tried to start the service using /scripts/restartsrv_dovecot but cannot be started, and the output (/usr/local/cpanel/logs/tailwatchd_log):

    So:
    • checked via netstat: no port used by dovecot is being used.
    • checked via ps: no proccess dovecot is running
    • checked: /var/run/dovecot/master.pid does not exists
    • checked: no output at /var/log/maillog... no errors.
    Tried also:
    • /scripts/builddovecotconf with no error: the same, dovecot does not start
    Tried also executing from init.d/dovecot start but fails. The only message thrown is:


    It seems, there is no way to reset config or force reinstalling dovecot, and this is a production server, so clients are bombing our phones...

    Then, I figured out maybe if try to start dovecot binary directly through SSH terminal, some error may appear and give me a clue... but better: IF I START DOVECOT MANUALLY DOING...

    THEN DOVECOT STARTS, go to the background and nothing else.... now it is running...

    But if proccess launched manually gets killed, somehow or when I even make some changes via "service manager", the same problem.

    • restartsrv_dovecot cannot start it
    • init.d/dovecot cannot start it
    • tailwatchd cannot start it

    This way.... what could I do?

    It is WHM 11.52.0 (build 18) with last CSF installed. No problem at similar neighbour servers at all...

    Output from "service manager" when modifying...

     
  2. feanorknd

    feanorknd Member

    Joined:
    Sep 28, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hello...

    Answer my self for some other people in my case...

    First of all, cpanel support was excellent... they fixed they """issue""". 13 hours for first answer, but very well done... happy with them :-D

    The problem was:
    • I have had a screen session, running something like "tail -f /var/log/mailllog | grep dovecot"
    And that is all... we could consider this is half the problem, because really, I think the other half is:
    • Cpanel scripts does review "ps" proccesses to find out if dovecot already running. But they do this bad, really bad, because that "grep dovecot" running, make cpanel scripts believe that there is running dovecot instance and try to kill it... because it is not really dovecot (but grep), as dovecot were dead, really dead, the cpanel scripts finish without starting dovecot at all.
    Seriously? Yes.

    You can test: put any kind of proccess using "dovecot" as parameter, and cpanel scripts are not able to restart or start dovecot.

    I think cpanel guys may fix their scripts to filter a bit better.... "grep dovecot" is not Dovecot daemon at all.

    Regards.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,745
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I am happy to see the issue is now resolved. To note, internal case FB-99361 was opened to address this issue in the past, and it's no longer reproducible on cPanel version 11.52.

    Thank you.
     
Loading...

Share This Page