Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Dovecot Imap: Warning: fd limit (ulimit -n) is lower than required under max

Discussion in 'E-mail Discussion' started by martin MHC, Feb 15, 2019.

Tags:
  1. martin MHC

    martin MHC Well-Known Member

    Joined:
    Sep 14, 2016
    Messages:
    141
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hello

    When editing the WHM » Home »Service Configuration »Mailserver Configuration

    and saving; the notice:


    Is displayed. However despite adjusting some settings in "Mailserver Configuration" I can't seem to adjust either value (client_limit or fd limit ).

    Things I have done:

    I have read this post: Warning: fd limit is lower than required under max. load but the solution offered (CMD update in Terminal of ulimit -n <number> ) does not change values (including after restarting services).

    I have read this post: Starting Dovecot Imap: Warning: fd limit (ulimit -n) is lower than required under max and Shell Fork Bomb Protection IS enabled on my server and I am not keen on turning this off (due to users and terminal etc.) .

    I have read this post: dovecot error and the solution offered of editing the Dovecot 2.2 template file -- this has been done, but no
    "default_client_limit" value exists in the template, however I can adjust the "client_limit" in the /etc/dovecot/dovecot.conf file, setting it to a value below 1024 ( 1000 ) but now presents a different message when restarting dovecot:

    Changing the same value to a value above 1100 results in the first error above.

    How do I correctly resolve this issue?

    Cheers
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @martin MHC,

    Can you verify which cPanel & WHM version is installed on this system? Also, which release tier is the affected system configured to use?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. martin MHC

    martin MHC Well-Known Member

    Joined:
    Sep 14, 2016
    Messages:
    141
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hello @cPanelMichael
    This is WHM 76.0.11 on the Recommended tier (just about to be updated to WHM 78, so will see if this blip is ironed out on that update).
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Let me know if the issue persists on version 78. We included a change to increase the Dovecot RLimit value as part of CPANEL-25070.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. martin MHC

    martin MHC Well-Known Member

    Joined:
    Sep 14, 2016
    Messages:
    141
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hello @cPanelMichael - After updating to 78.0.11 I have not seen the above notice; I have only been running WHM 78 for a few days so maybe early to note but I believe this issue is resolved. Fingers crossed!

    Thanks.
     
    cPanelMichael likes this.
  6. martin MHC

    martin MHC Well-Known Member

    Joined:
    Sep 14, 2016
    Messages:
    141
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hello @cPanelMichael . I have been looking at the server process log but not seen this occur since the update to 78.0.11 so I think it may be resolved. (Maybe mark this as solved?)

    Cheers

    Martin
     
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,009
    Likes Received:
    2,123
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi Martin,

    I'm glad to see the issue is no longer occurring in version 78. I've marked this thread as solved.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice