The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

dovecot not restarted when changing ssl cert

Discussion in 'General Discussion' started by dclaw, Dec 4, 2008.

  1. dclaw

    dclaw Member

    Aug 24, 2007
    Likes Received:
    Trophy Points:
    Escondido, CA

    I just ran into and solved the following issue:

    We had a customer using ssl to connect via pop to our server. We recently converted to dovecot when 11.24 came out.

    The customer was receiving an error saying that the ssl cert had a bad signature, etc... Turns out it was expired. For some reason during the cpanel upgrade, it seemed to have grabbed an old server cert to use with dovecot, this cert differed from the cert in use with ftp / cpanel/whm / and smtp.

    I tried reinstalling the new certificate, but it seemed it wasn't taking, as the error persisted.

    I finally ended up restarting dovecot manually on the command line "service dovecot restart" and then it suddenly worked.

    It seems as if WHM isn't restarting dovecot properly when a new ssl cert is installed via " Main >> Service Configuration >> Manage Service SSL Certificates"

    Any devs have ideas on this?


Share This Page