Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Dovecot policy server HTTP error 9002 after cPanel upgrade

Discussion in 'E-mail Discussion' started by kalexanakis, Apr 18, 2017.

  1. kalexanakis

    kalexanakis Member

    Joined:
    Feb 3, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    Hello

    After upgrading cPanel to cPanel & WHM 64.0 (build 12) customers experience time outs connecting to mail server. In / var/log/messages I see multiple instances of

    Apr 18 11:25:17 SERVER_NAME dovecot: auth: Error: policy(xxx@xxx.xxx, xxx.xxx.xxx.xxx,<xxxxxx>): Policy server HTTP error: 9002 connect(127.0.0.1:579) failed: Connection refused

    for all accounts (XXXs are per incident different).

    - i have restarted imap and exim
    - fixed mailbox permissions

    I thing that the problem occured after auto ssl installation.

    Any thoughts?
     
    #1 kalexanakis, Apr 18, 2017
    Last edited by a moderator: Apr 18, 2017
  2. kalexanakis

    kalexanakis Member

    Joined:
    Feb 3, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    It seems that the problem had to do with cPHulk. I saw many errors in cpanel error_log like

    Brute force checking was skipped for the “xxx@xxx” from “xxxx” for the “mail” service because the system could not connect to cphulkd. at /usr/local/cpanel/Cpanel/Server.pm line 1896.

    Usually this occured in the past due to corrupted cphulk MySQL database but that was not the case now (tables where just fine).

    After stopped and restarted cphulk, smtp connections seem to work ok now (no cphulkd errors in cpanel error_log)

    I would like to know what have happened though...
     
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    The following error message may appear in /var/log/maillog on systems where POP3/IMAP users are unable to authenticate:

    Code:
    Policy server HTTP error: 9002 connect(127.0.0.1:579) failed: Connection refused
    This happens when cPHulkd fails to bind on port 579. Restarting cPHulkd should correct the issue:

    Code:
    /scripts/restartsrv_cphulkd
    Additionally, it's a good idea to enable monitoring for the "cPHulk Daemon" service via "WHM >> Service Manager" to ensure the service is automatically restarted should it fail again in the future.

    Note: Internal case CPANEL-12290 addresses an issue in cPanel 64 where the cPHulkd Chkservd driver was not ensuring the service was listening on port 579. The resolution is included in cPanel 64.0.13:

    Fixed case CPANEL-12290: Update cphulkd chkservd driver to ensure port 579 is working.


    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #3 cPanelMichael, Apr 18, 2017
    Last edited: Jun 26, 2017
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice