Jaison V John

Member
Apr 15, 2016
17
3
3
India
cPanel Access Level
Root Administrator
Hi cPanelMichael,

Is there any way to downgrade systemd in a CentOS 7.3 EA 4 server which is facing the error shown below?

Code:
----------------------------------------------------------------------------
 ~]# /scripts/restartsrv_httpd
Failed to execute operation: Connection timed out
Waiting for “httpd” to restart gracefully …Failed to execute operation: Connection timed out
AH00112: Warning: DocumentRoot [/home/dus09oi/public_html/industrialfloors.indusfloors.com] does not exist
waiting for “httpd” to initialize ………finished.

Service Status
    httpd (/usr/local/cpanel/bin/splitlogs --main=hostname --suffix=-bytes_log) is running as root with PID 1657 (systemd check method).
    httpd (/usr/local/cpanel/bin/splitlogs --main=hostname --mainout=/etc/apache2/logs/access_log) is running as root with PID 1658 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as nobody with PID 1663 (systemd check method).
    httpd (/usr/local/cpanel/3rdparty/bin/perl /usr/local/cpanel/bin/leechprotect) is running as root with PID 1664 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as nobody with PID 1665 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as nobody with PID 1666 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as nobody with PID 1667 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as nobody with PID 1668 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as root with PID 6114 (systemd check method).
    httpd (/usr/local/cpanel/bin/splitlogs --main=serverhostname--mainout=/etc/apache2/logs/access_log) is running as root with PID 6122 (systemd check method).
    httpd (/usr/sbin/httpd -k start) is running as nobody with PID 6138 (systemd check method).

Startup Log

Removed as it has the hostname.

Log Messages
    [Fri Jun 02 02:30:08.281567 2017] [mpm_worker:notice] [pid 6114:tid 140152041212032] AH00292: Apache/2.4.25 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations

httpd restarted successfully.


]# cat /etc/redhat-release
CentOS Linux release 7.3.1611 (Core)

~]# pidof httpd
19428 19288 19258 19196 19145 19143 7069

~]# rpm -qi systemd
Name        : systemd
Version     : 219
Release     : 30.el7_3.9
Architecture: x86_64
Install Date: Thursday 01 June 2017 10:40:21 PM IST
Group       : Unspecified
Size        : 22331373
License     : LGPLv2+ and MIT and GPLv2+
Signature   : RSA/SHA256, Friday 26 May 2017 05:01:38 AM IST, Key ID 24c6a8a7f4a80eb5
Source RPM  : systemd-219-30.el7_3.9.src.rpm
Build Date  : Friday 26 May 2017 02:53:29 AM IST
Build Host  : c1bm.rdu2.centos.org
Relocations : (not relocatable)
Packager    : CentOS BuildSystem <My View - CentOS Bug Tracker>
Vendor      : CentOS
URL         : systemd
Summary     : A System and Service Manager


 ~]# yum downgrade systemd
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
 * EA4: 69.72.212.10
 * cpanel-addons-production-feed: 69.72.212.10
 * base: mirrors.greenmountainaccess.net
 * epel: epel.mirror.constant.com
 * extras: mirror.umd.edu
 * updates: mirror.netdepot.com
Resolving Dependencies
--> Running transaction check
---> Package systemd.x86_64 0:219-30.el7_3.8 will be a downgrade
--> Processing Dependency: systemd-libs = 219-30.el7_3.8 for package: systemd-219-30.el7_3.8.x86_64
---> Package systemd.x86_64 0:219-30.el7_3.9 will be erased
--> Running transaction check
---> Package systemd.x86_64 0:219-30.el7_3.9 will be erased
---> Package systemd-libs.i686 0:219-30.el7_3.8 will be installed
--> Processing Dependency: libselinux.so.1 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: librt.so.1(GLIBC_2.3.4) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: librt.so.1 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libresolv.so.2 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.2) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpthread.so.0 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libpam.so.0 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libm.so.6 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: liblzma.so.5 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgpg-error.so.0 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgcrypt.so.11 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libgcc_s.so.1 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libdw.so.1 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libdl.so.2 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libcap.so.2 for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: libc.so.6(GLIBC_2.9) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: systemd-libs-219-30.el7_3.8.i686
--> Processing Dependency: ld-linux.so.2 for package: systemd-libs-219-30.el7_3.8.i686
--> Running transaction check
---> Package elfutils-libs.i686 0:0.166-2.el7 will be installed
--> Processing Dependency: elfutils-libelf(x86-32) = 0.166-2.el7 for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libz.so.1(ZLIB_1.2.2.3) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libz.so.1 for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.7) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.6) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.5) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.4) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.3) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.1.1) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.0) for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libelf.so.1 for package: elfutils-libs-0.166-2.el7.i686
--> Processing Dependency: libbz2.so.1 for package: elfutils-libs-0.166-2.el7.i686
---> Package glibc.i686 0:2.17-157.el7_3.2 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-157.el7_3.2.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-157.el7_3.2.i686
---> Package libcap.i686 0:2.22-8.el7 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-8.el7.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.22-8.el7.i686
---> Package libgcc.i686 0:4.8.5-11.el7 will be installed
---> Package libgcrypt.i686 0:1.5.3-13.el7_3.1 will be installed
---> Package libgpg-error.i686 0:1.12-3.el7 will be installed
---> Package libselinux.i686 0:2.5-6.el7 will be installed
--> Processing Dependency: libsepol(x86-32) >= 2.5-6 for package: libselinux-2.5-6.el7.i686
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-6.el7.i686
--> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-6.el7.i686
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-6.el7.i686
---> Package pam.i686 0:1.1.8-18.el7 will be installed
--> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-18.el7.i686
--> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-18.el7.i686
--> Processing Dependency: libaudit.so.1 for package: pam-1.1.8-18.el7.i686
---> Package systemd.x86_64 0:219-30.el7_3.9 will be erased
---> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package audit-libs.i686 0:2.6.5-3.el7_3.1 will be installed
--> Processing Dependency: libcap-ng.so.0 for package: audit-libs-2.6.5-3.el7_3.1.i686
---> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
---> Package cracklib.i686 0:2.9.0-11.el7 will be installed
---> Package elfutils-libelf.i686 0:0.166-2.el7 will be installed
---> Package libattr.i686 0:2.4.46-12.el7 will be installed
---> Package libdb.i686 0:5.3.21-19.el7 will be installed
---> Package libsepol.i686 0:2.5-6.el7 will be installed
---> Package nss-softokn-freebl.i686 0:3.16.2.3-14.4.el7 will be installed
---> Package pcre.i686 0:8.32-15.el7_2.1 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-15.el7_2.1.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-15.el7_2.1.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-15.el7_2.1.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-15.el7_2.1.i686
---> Package systemd.x86_64 0:219-30.el7_3.9 will be erased
---> Package zlib.i686 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
---> Package libstdc++.i686 0:4.8.5-11.el7 will be installed
---> Package systemd.x86_64 0:219-30.el7_3.9 will be erased
--> Finished Dependency Resolution
Error: Package: systemd-sysv-219-30.el7_3.9.x86_64 (@updates)
           Requires: systemd = 219-30.el7_3.9
           Removing: systemd-219-30.el7_3.9.x86_64 (@updates)
               systemd = 219-30.el7_3.9
           Downgraded By: systemd-219-30.el7_3.8.x86_64 (updates)
               systemd = 219-30.el7_3.8
           Available: systemd-219-30.el7.x86_64 (base)
               systemd = 219-30.el7
           Available: systemd-219-30.el7_3.3.x86_64 (updates)
               systemd = 219-30.el7_3.3
           Available: systemd-219-30.el7_3.6.x86_64 (updates)
               systemd = 219-30.el7_3.6
           Available: systemd-219-30.el7_3.7.x86_64 (updates)
               systemd = 219-30.el7_3.7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

----------------------------------------------------------------------------
The strace result for httpd restart is attached here.

This looks like a bug in the systemd version as per a quick google search, but the cPanel is not allowing me to downgrade the systemd version to sort this out.

Any recommendations is highly appreciated.
 

Attachments

Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,211
363
Hello,

Could you verify if you have tried rebooting the server? This isn't typically recommended, but I found a similar report of this problem opened as a support ticket earlier this year and a server reboot was performed to ensure the child daemons for systemd started up correctly.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,211
363
Hello,

Would you mind opening a support ticket using the link in my signature so we can take a closer look?

Thank you.
 

Jaison V John

Member
Apr 15, 2016
17
3
3
India
cPanel Access Level
Root Administrator
Hi @cPanelMichael,

I'm extremely sorry for the delay in replying to you. I was away from my box for a few days. Btw, we did manage to bring down the server resources abuse by replacing a drive in the RAID 1 array which was showing signs of the failure.

This reduced the IO consumption in the server and in turn sorted out the problem with the systemd timeout on the server.

Good day ahead!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,211
363
I'm glad to see you were able to address the issue. Thank you for updating us with the outcome.