easyswiss

Active Member
PartnerNOC
Apr 19, 2011
44
1
58
We want to downgrade from the Buggy :confused: Easyapache 4 to Easyapache 3.

Fresh Installation!

- Breaks Cloudlinux PHP Selector (PHP Manager have no feature to select the modules)
- Hangs with Easyapache 4 Customising
- Need 20 min to load Customising with other profiles

Means... waste my time :mad:

How to use the working Easyapache 3 with WHM 58.0 (build 32)?
There are a lot of entries here from other users...

I don't want to play with Alpha Versions!
 
Last edited by a moderator:

easyswiss

Active Member
PartnerNOC
Apr 19, 2011
44
1
58
Example of Step 4 (Fresh cPanel Installation!):
Code:
Update Error: Error: Package: ea-apache24-mod_expires-2.4.23-3.6.2.cpanel.x86_64 (EA4) Requires: ea-apache24 = 2.4.23-3.6.2.cpanel Installed: 1:ea-apache24-2.4.23-3.el6.cloudlinux.x86_64 ([USER=7336]@cl[/USER]-ea4) ea-apache24 = 1:2.4.23-3.el6.cloudlinux Available: ea-apache24-2.4.16-4.1.x86_64 (EA4) ea-apache24 = 2.4.16-4.1 Available: ea-apache24-2.4.16-4.2.x86_64 (EA4) ea-apache24 = 2.4.16-4.2 Available: ea-apache24-2.4.16-4.3.x86_64 (EA4) ea-apache24 = 2.4.16-4.3 Available: ea-apache24-2.4.16-5.1.x86_64 (EA4) ea-apache24 = 2.4.16-5.1 Available: ea-apache24-2.4.16-6.1.x86_64 (EA4) ea-apache24 = 2.4.16-6.1 Available: ea-apache24-2.4.16-6.2.x86_64 (EA4) ea-apache24 = 2.4.16-6.2 Available: ea-apache24-2.4.16-8.1.x86_64 (EA4) ea-apache24 = 2.4.16-8.1 Available: ea-apache24-2.4.16-9.1.x86_64 (EA4) ea-apache24 = 2.4.16-9.1 Available: ea-apache24-2.4.17-1.1.x86_64 (EA4) ea-apache24 = 2.4.17-1.1 Available: ea-apache24-2.4.17-2.1.x86_64 (EA4) ea-apache24 = 2.4.17-2.1 Available: ea-apache24-2.4.17-3.1.x86_64 (EA4) ea-apache24 = 2.4.17-3.1 Available: ea-apache24-2.4.17-3.2.x86_64 (EA4) ea-apache24 = 2.4.17-3.2 Available: ea-apache24-2.4.17-3.3.x86_64 (EA4) ea-apache24 = 2.4.17-3.3 Available: ea-apache24-2.4.18-1.1.x86_64 (EA4) ea-apache24 = 2.4.18-1.1 Available: ea-apache24-2.4.18-2.1.x86_64 (EA4) ea-apache24 = 2.4.18-2.1 Available: ea-apache24-2.4.18-3.1.x86_64 (EA4) ea-apache24 = 2.4.18-3.1 Available: ea-apache24-2.4.18-4.1.x86_64 (EA4) ea-apache24 = 2.4.18-4.1 Available: ea-apache24-2.4.18-5.1.x86_64 (EA4) ea-apache24 = 2.4.18-5.1 Available: ea-apache24-2.4.18-5.2.x86_64 (EA4) ea-apache24 = 2.4.18-5.2 Available: ea-apache24-2.4.18-6.1.x86_64 (EA4) ea-apache24 = 2.4.18-6.1 Available: ea-apache24-2.4.18-7.1.x86_64 (EA4) ea-apache24 = 2.4.18-7.1 Available: ea-apache24-2.4.20-1.1.x86_64 (EA4) ea-apache24 = 2.4.20-1.1 Available: ea-apache24-2.4.20-2.1.x86_64 (EA4) ea-apache24 = 2.4.20-2.1 Available: ea-apache24-2.4.20-3.1.x86_64 (EA4) ea-apache24 = 2.4.20-3.1 Available: ea-apache24-2.4.20-4.4.4.x86_64 (EA4) ea-apache24 = 2.4.20-4.4.4 Available: ea-apache24-2.4.20-4.5.1.cpanel.x86_64 (EA4) ea-apache24 = 2.4.20-4.5.1.cpanel Available: ea-apache24-2.4.20-6.6.1.cpanel.x86_64 (EA4) ea-apache24 = 2.4.20-6.6.1.cpanel Available: ea-apache24-2.4.23-1.1.1.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-1.1.1.cpanel Available: ea-apache24-2.4.23-2.2.1.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-2.2.1.cpanel Available: ea-apache24-2.4.23-2.2.2.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-2.2.2.cpanel Available: ea-apache24-2.4.23-3.3.1.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-3.3.1.cpanel Available: ea-apache24-2.4.23-3.3.2.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-3.3.2.cpanel Available: ea-apache24-2.4.23-3.3.3.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-3.3.3.cpanel Available: ea-apache24-2.4.23-3.6.2.cpanel.x86_64 (EA4) ea-apache24 = 2.4.23-3.6.2.cpanel Error: Package: ea-php55-php-calendar-5.5.38-4.4.4.cpanel.x86_64 (EA4) Requires: ea-php55-php-common(x86-64) = 5.5.38-4.4.4.cpanel Installed: 1:ea-php55-php-common-5.5.38-4.el6.cloudlinux.x86_64 ([USER=7336]@cl[/USER]-ea4)

..... and many more

Please review the following list of packages you are about to install by provisioning this profile.
There are no packages to be installed.

Please review the following list of packages you are about to upgrade by provisioning this profile.
There are no packages to be upgraded.

Please review the following list of packages you are about to uninstall by provisioning this profile.
There are no packages to be uninstalled.

These packages will not be affected by provisioning this profile.
There are no packages remaining unchanged.
 
Last edited by a moderator:

Bazinga

Active Member
Verifed Vendor
Aug 23, 2016
32
7
8
Ukraine
cPanel Access Level
Website Owner
We want to downgrade from the Buggy :confused: Easyapache 4 to Easyapache 3.

Fresh Installation!

- Breaks Cloudlinux PHP Selector (PHP Manager have no feature to select the modules)
- Hangs with Easyapache 4 Customising
- Need 20 min to load Customising with other profiles

Means... waste my time :mad:

How to use the working Easyapache 3 with WHM 58.0 (build 32)?
There are a lot of entries here from other users...

I don't want to play with Alpha Versions!
About selecting modules with PHP-Selector - better to open support ticket at https://helpdesk.cloudlinux.com/
 

easyswiss

Active Member
PartnerNOC
Apr 19, 2011
44
1
58
Ok, the support found a solution to fix:

Code:
cd ~; wget https://repo.cloudlinux.com/cloudlinux/sources/cloudlinux_ea3_to_ea4; sh cloudlinux_ea3_to_ea4 --revert
cd ~; wget https://repo.cloudlinux.com/cloudlinux/sources/cloudlinux_ea3_to_ea4; sh cloudlinux_ea3_to_ea4 --convert
Build EA4

Code:
cagefsctl --setup-cl-selector
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello @easyswiss,

Thank you for taking the time to offer feedback on your experience with EasyApache 4. I'm happy to see the issue with CloudLinux's PHP Selector is now addressed. You will also notice significant speed improvements with the EasyApache 4 UI in cPanel version 60. This is detailed on the following section of the cPanel 60 Release Notes:

60 Release Notes - Documentation - cPanel Documentation

Let us know if we can be of any further assistance.

Thank you.