The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Downgrading to PHP 5.2

Discussion in 'EasyApache' started by se7enphoenix, Aug 4, 2014.

  1. se7enphoenix

    se7enphoenix Registered

    Aug 4, 2014
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hi: Unfortuantely, I have a number of sites that are dependent on PHP 5.2 and I am currently upgrading to a server that only support PHP 5.3+.

    I know it is not officially supported any longer, but I am trying to do the downgrade via the Custom Module.

    I have been at this for 14 hours straight and finally, I keep getting the same error:

    /bin/sh /home/cpeasyapache/src/php-5.2.17/libtool --silent --preserve-dup-deps --mode=install cp ext/sqlite/ /home/cpeasyapache/src/php-5.2.17/modules
    Build complete.
    Don't forget to run 'make test'.
        -- End step 'make php for apache and cli' --
        -- Begin step 'make install php for apache and cli' --
    Installing PHP SAPI module:       apache2handler
    /usr/local/apache/build/ SH_LIBTOOL='/usr/local/apache/build/libtool' /usr/local/apache/modules
    /usr/local/apache/build/libtool --mode=install cp /usr/local/apache/modules/
    libtool: install: error: cannot install `' to a directory not ending in /home/cpeasyapache/src/php-5.2.17/libs
    apxs:Error: Command failed with rc=65536
    make: *** [install-sapi] Error 1
    Any ideas on how to fix this?
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    Here is a quote from our EasyApache product owner on another recent thread:

    My advice would be to work on getting those scripts upgraded to work with PHP version 5.3 or higher. It's getting close to 4 years since PHP 5.2 reached end-of-life. The following guide is provided by PHP:

    A guide is available for migrating from PHP 5.2 to 5.3

    Thank you.

Share This Page