The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Download speed limit in cPanel

Discussion in 'Workarounds and Optimization' started by istav555, Nov 17, 2011.

  1. istav555

    istav555 Member

    Joined:
    Sep 8, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Is there ANY kind of setting that limits the download speed for client's websites?

    It seems I have a constant 400kb/s hard limit in every download. I searched everything but cannot find anything related to that in cPanel... Any ideas?

    I double checked with another VPS, on the same dedicated server (I manage the dedi), same VLAN, with no cPanel installed, and from there I constantly max out my connections at 1.5mbit/s.
     
  2. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    I don't think there is an option in cpanel in order to limit the download speed.I am only aware about the bandwidth limitation.May be cpanel staff is knows better about this
     
  3. istav555

    istav555 Member

    Joined:
    Sep 8, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes, this is what I think too after some investigation on the issue. I did saw some indications that the bandwidth module might have something to do with connection speed too but its not a very credible source.

    Maybe cPanel stuff knows something more.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You might look at these two directives in Apache:

    mpm_common - Apache HTTP Server
    core - Apache HTTP Server

    For EnableSendfile, set it to Off if it is set to On to see the results.

    You could set these in /usr/local/apache/conf/includes/pre_main_global.conf file simply by entering the values you want for each directive into the file, then restarting Apache.

    What I am thinking is that it is Apache that is limiting these in some way due to differing settings between the Apache on the one machine and Apache on the cPanel one.
     
  5. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    hi,

    i have read the docs and i am little bit confused , suppose i need to limit the download speed for one domain , how can i implement that , can you give an example , because as per reading the doc , i can see that we can only set the " EnableSendfile " globally and its not specifying how to limit the speed , its only show how to enable this feature .

    And one more thing is what about the client is using another service like " ftp " other that " http " in order to download the files ?

    your replay is much appreciated

    thank you in advance , for pointing to the solution :)
     
  6. istav555

    istav555 Member

    Joined:
    Sep 8, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you very much for your help but it turned out that it wasn't a cPanel or CentOS problem. Hyper-V was the problem. It seems Hyper-V doesn't play well with some NICs. Even enterprise grade NICs can have problems. Anyway, installed cPanel on a dedicated server (this was the plan for a later stage but its ok) and everything works as it should.

    I guess Hyper-V is not mature enough yet. Its a shame because it is way cheaper than VMWare. But maybe this is to be expected, you get what you pay for...
     
Loading...

Share This Page