tortuga

Member
Oct 16, 2018
7
0
1
United Kingdom
cPanel Access Level
Website Owner
I manage a website that used to run on a couple of other domains which need to forward to the current one. In the past, I was advised to add them as add-ons and redirect, but Google started indexing the main site content on at least one of them. So I changed them to alias domains with redirects, and it was okay for a while, but now the problem has recurred. From what I can see, it seems to be connected with the extra domains not having valid SSL certificates, which breaks the redirects on https, and then Google somehow discovers the content on the main domain. I concluded this because the additional domains are usually, but not always, indexed as https, and also the problem did not occur before the main domain migrated to https. It's annoying because there don't need to be any redirects from https as the old domains never ran on it, but seemingly cPanel insists on activating https for every domain added to the account.

So I ended up reverting them to add-ons and buying certificates so that the redirects work over https, but whether this will resolve the problem remains to be seen. But I have a few questions:

1. Is my diagnosis of the cause of the problem accurate? Or could it be something else?
2. If so, is there a way to resolve it without buying signed certificates? It's annoying when all you want to do is redirect.
3. What is the difference between redirecting add-on domains and alias domains? Which is preferable for what I want?
4. Would it help to have the domains on a different cPanel account or a different registrar altogether? I'm thinking it wouldn't because they would be pointing to the website content anyway.
5. Is there a way in cPanel to disable https altogether on specific domains? I've tried removing the self-signed certificates but it doesn't seem to help.

Thanks
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
I would assume that Google is finding the content on the main domain when the aliased domain fails on https because of the way that apache serves https VirtualHosts - it's going to load the first SSL VirtualHost in the configuration for that IP address if the domain does not have an SSL.

cPanel offers free 90-day SSL certificates if you don't have those available I would suggest contacting your provider. Really, the only way to resolve this specific issue would be to use an SSL certificate unless you remove the redirects to https and/or force http only for sites without SSL certs.

An alias is a redirect in a way but essentially you're parking that domain on top of another domain, so it will use the domain name but have the content of the other site, a redirect is going to take you to the other site.

Thanks!
 

tortuga

Member
Oct 16, 2018
7
0
1
United Kingdom
cPanel Access Level
Website Owner
I would assume that Google is finding the content on the main domain when the aliased domain fails on https because of the way that apache serves https VirtualHosts - it's going to load the first SSL VirtualHost in the configuration for that IP address if the domain does not have an SSL.

cPanel offers free 90-day SSL certificates if you don't have those available I would suggest contacting your provider. Really, the only way to resolve this specific issue would be to use an SSL certificate unless you remove the redirects to https and/or force http only for sites without SSL certs.

An alias is a redirect in a way but essentially you're parking that domain on top of another domain, so it will use the domain name but have the content of the other site, a redirect is going to take you to the other site.

Thanks!
Thanks for the response. Yes, it's finding the main content because of the redirects being broken by the lack of valid SSL certificates. You mentioned that you can force http only - how do you do that?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,273
313
Houston
An .htaccess redirect would do the trick - something like this might work:

Code:
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule ^ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]