Dynamic Email Address making subfolders

sHORTYWZ

Well-Known Member
Dec 14, 2003
49
1
156
Not sure if this is more of an Exim issue or a CP issue, but hoping someone can point me in the right direction.

My forum software uses dynamic email addressing for bounce handling and sends out return addresses such as :

[email protected]

When I check in the 'xenbounce' account, the folder structure is a bit weird.

The above email wound end up in '5a7bd4e8+dave=myemail' and then a subfolder of 'com' would be created under that folder which would then contain the email.

Is there a way to avoid the second layer of folders being created and just have it go to '5a7bd4e8+dave=myemail.com' as I believe this is the intended behavior?
 

rpvw

Well-Known Member
Jul 18, 2013
1,088
446
113
UK
cPanel Access Level
Root Administrator
I am guessing that is being caused by the new Email subaddresses feature

Email subaddresses
This feature, also known as plus addressing, allows senders to route a message directly to the folder of a mailbox.

Email subaddresses use the [email protected] format, where username represents the username of the mailbox and folder represents the folder's name.

For example, if you send a message to [email protected], the mail server will route the message to the Important folder in the [email protected] mailbox.

Notes:
  • If the folder does not already exist, the system will create that folder.
  • You must subscribe to the folder in your email or webmail client for the folder to appear.
Possibly the repeated '+', or the inclusion of what appears to be a domain in the address part after the '+', is confusing it ?

Full details from Email Accounts - Version 68 Documentation - cPanel Documentation

Unfortunately, it does not look like it is possible to disable the Email subaddresses at this time. See the following thread for more information How to disable Email subaddresses
 
Last edited: