The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DynDNS type service in WHM?

Discussion in 'Bind / DNS / Nameserver Issues' started by genesis, Jul 27, 2005.

  1. genesis

    genesis Registered

    Joined:
    Jul 27, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Greetings,

    I've been a very long time user of WHM and cPanel but first time posting with a question. I've been using DynDNS.org service but now I'm looking into this feature for my personal use. I have access to WHM and cPanel on my dedicated (remote) RH7.2 Linux server.

    What I want is to be able to access my home computer (Static IP) by typing in an address http://homecomputer.mydomain.com. But I also want to have access to wildcard, just like DynDNS's service. So for example if I want to access my home router, I'd type in http://homecomputer.mydomain.com:8080 and still be able to access it.

    How can I achieve this?

    Thank you very much for generous assistance.

    genesis.
     
  2. zach21uk

    zach21uk Member

    Joined:
    Jul 24, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    not sure if this'll work but i think it will

    goto the DNS settings for your domain, and add an entry as follows:

    homecomputer 88400 in A 0 xxx.xxx.xxx.xxx

    where the xxx's are, put in your ip.

    this should create a subdomain on ur domain, so when u goto homecomputer.yourdomain.com it should take you to your static ip.........
     
  3. ctbhost

    ctbhost Well-Known Member

    Joined:
    May 31, 2002
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    i have personally had success in doing what you want

    all i did was set up a subdomain bla.mydomain.com in whm

    then go in to the EDIT DNS zone and change the a record ip address to your static IP

    of course you would need a web server running on your home computer running on port 80 and make sure your ISP dont block port 80 like some do
     
  4. genesis

    genesis Registered

    Joined:
    Jul 27, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply guys, although I found out like 10 minutes after posting this, I did exactly the same and all works nicely.
     

Share This Page