E-mail Accounts disappeared

an4rei

Registered
Jul 24, 2019
2
0
1
Romania
cPanel Access Level
Root Administrator
Hello!
Today I did the mistake of creating a subdomain for 'mail.domain.com'. It returned an error telling me that there is already a DNS record pointing to this certain subdomain but it still created it.
After finding out that I can't send mails anymore I deleted the subdomain, restarted cpanel service, imap server from whm, httpd service restarted as well. The problem persisted.

Therefore I logged into the cPanel -> email accounts and found out that I only have the default user e-mail added([email protected]) but the E-mail Count in the right corner was correct(it was the old one, probably due to cache).

What should I do? I see all my mail accounts and other domains in home/cpaneluser/mail.
I can't authenticate on any old e-mails and they also don't appear in cpanel.

Thank you!
 

an4rei

Registered
Jul 24, 2019
2
0
1
Romania
cPanel Access Level
Root Administrator
I have re-created one e-mail for a user and it looks like it didnt delete its emails. It got all of them but I had to change the password for the account. I really would like to avoid re-creating emails for every account with different passwords.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
While that shouldn't have happened for creating the subdomain, it sounds like /home/user/etc/ was removed, which would, in turn, remove the user's passwd and shadow files and leave the email accounts with mail in them but not displayed in the UI. If you're still having trouble with this, can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!