Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

E-mail delivery locally and not remotely

Discussion in 'E-mail Discussion' started by Jasonbd, Nov 19, 2004.

  1. Jasonbd

    Jasonbd Member

    Joined:
    Jan 4, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Texas
    Hello,

    First thanks in advice for helping out. I have a domain name that is hosted on my server. Currently they have not switched DNS to my server and they are still pointing to ipowerweb. I have already setup there domain name on my server and they have already setup the same e-mail account.

    If i send them an e-mail from my server it tries to deliver locally instead of looking remotely. In the logs I get this error message.

    T=local_delivery defer (122): Disk quota exceeded: mailbox is full
    Return to Mail Queue

    Its trying to deliver locally instead of doing a look up on the domain name which if i do a dig from my server on the domain name it gives the following:

    *NOTE* I replaced the domain name to ensure privacy

    ; <<>> DiG 9.2.4rc6 <<>> ns
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11328
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 4

    ;; QUESTION SECTION:
    ;domain.com. IN NS

    ;; ANSWER SECTION:
    domain.com. 3103 IN NS ns1.ipowerdns.com.
    domain.com. 3103 IN NS ns2.ipowerweb.net.
    domain.com. 3103 IN NS ns2.ipowerdns.com.
    domain.com. 3103 IN NS ns1.ipowerweb.net.

    ;; ADDITIONAL SECTION:
    ns1.ipowerdns.com. 145109 IN A 66.235.217.202
    ns2.ipowerweb.net. 34873 IN A 66.235.217.200
    ns2.ipowerdns.com. 137940 IN A 64.70.61.131
    ns1.ipowerweb.net. 34873 IN A 64.70.61.130

    ;; Query time: 2 msec
    ;; SERVER: 64.39.2.170#53(64.39.2.170)
    ;; WHEN: Fri Nov 19 18:15:06 2004
    ;; MSG SIZE rcvd: 188

    This is a ns dig lookup. Why is it trying to deliver locally and not remotely.

    My /etc/resolve.conf is the following:

    root@web1 [/home/www]# cat /etc/resolv.conf

    nameserver 64.39.2.170
    nameserver 64.39.2.138
    root@web1 [/home/www]#

    Thanks
    Jason B.
     
  2. fwwebs

    fwwebs Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    329
    Likes Received:
    0
    Trophy Points:
    166
    I believe it's doing this because the domain is listed in /etc/localdomains.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice