The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

e-mail forwarding issue

Discussion in 'E-mail Discussions' started by ahevans, Sep 3, 2008.

  1. ahevans

    ahevans Member

    Joined:
    Aug 23, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    hi, I have set up e-mail forwarding so that if anybody e-mails a particular address from my domain it is forwarded to A Gmail account that I own.

    However all e-mails are getting stuck in the mail queue in whm and if I try to manually send the mail I get the following error

    Message 1KeeNm-1234h4-AQ is no longer frozen
    delivering 1KeeNm-1234h4-AQ
    Connecting to gmail-smtp-in.l.google.com [209.85.133.114]:25 ... failed: Connection refused
    LOG: MAIN
    gmail-smtp-in.l.google.com [209.85.133.114] Connection refused
    Connecting to gmail-smtp-in.l.google.com [209.85.133.27]:25 ... failed: Connection refused
    LOG: MAIN
    gmail-smtp-in.l.google.com [209.85.133.27] Connection refused
    Connecting to alt2.gmail-smtp-in.l.google.com [209.85.147.27]:25 ... failed: Connection refused
    LOG: MAIN
    alt2.gmail-smtp-in.l.google.com [209.85.147.27] Connection refused
    Connecting to alt1.gmail-smtp-in.l.google.com [209.85.135.27]:25 ... failed: Connection refused
    LOG: MAIN
    alt1.gmail-smtp-in.l.google.com [209.85.135.27] Connection refused
    Connecting to alt1.gmail-smtp-in.l.google.com [209.85.135.114]:25 ... failed: Connection refused
    LOG: MAIN
    alt1.gmail-smtp-in.l.google.com [209.85.135.114] Connection refused
    Connecting to gsmtp183.google.com [64.233.183.27]:25 ... failed: Connection refused
    LOG: MAIN
    gsmtp183.google.com [64.233.183.27] Connection refused
    Connecting to gsmtp147.google.com [209.185.147.27]:25 ... failed: Connection refused
    LOG: MAIN
    gsmtp147.google.com [209.185.147.27] Connection refused
    LOG: MAIN
    == xx@gmail.com R=lookuphost T=remote_smtp defer (111): Connection refused
    LOG: MAIN
    ** xx@gmail.com: retry timeout exceeded
    LOG: MAIN
    xx@gmail.com: error ignored
    LOG: MAIN
    Completed


    Can anybody explain what is going wrong please?
     
  2. bornonline

    bornonline Well-Known Member

    Joined:
    Nov 19, 2004
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Not sure, but I would suggest configuring google to check that account instead of forwarding to it. This way you are not forwarding spam/junk to Google.

    Have you been forwarding for a while and this is new problem? Just set google to check that account and see if you get the email. This would be a much better practice anyway.
     
  3. ahevans

    ahevans Member

    Joined:
    Aug 23, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    hi, I am sending an e-mail from a Hotmail account to an address for a domain in my whm hosting setup which is then forwarded to the Gmail account. I have access to both accounts and when an e-mail is sent to the address that is being forwarded it just gets stuck in the mail queue and when I forced delivery the above error occurs
     
  4. ahevans

    ahevans Member

    Joined:
    Aug 23, 2008
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    hi, does no one know why this is happening or how to fix it?

    Thanks
     
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You are probably (or did at one time) sending spam either directly or indirectly to gmail.

    Either someone on your server is sending out spam to gmail account (Not necessarily you, it could be someone else that shares that IP). You may have a compromised script somewhere on your server that is sending out spam (again, not necessarily your account). Or there may be forwarders set up on your server that are forwarding spam to gmail (yet again, this does not necessarily apply to your account, but you have stated that you have forwarders set up).

    The best solution is to follow bornonline advice. Set up the e-mail addresses as regular POP accounts on your account. Or you can forward mail internally. If you have 50 @yourdomain.com e-mail addresses that you want to check, just set them all to forward to one collecting @yourdomain.com that is a POP account. Then delete all of the Gmail forwarders. Then log into your Gmail account and under the Settings, configure your Gmail account to log into the POP3 server on your server and download the mail.

    This way you are not pushing mail (and spam) to Gmail. You are telling Gmail to pull the messages from your server.
     
  6. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    Yup.
    Forwarding emails can really screw things up, because you are also forwarding spam. I try to limit all forwarders on the server, especially to AOL (which will just block you, versus google's delay).

    Set gmail to retrieve the mail. Do not forward.
     
Loading...

Share This Page