The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

E-mail piping for osTicket

Discussion in 'E-mail Discussions' started by SNewman, Oct 4, 2005.

  1. SNewman

    SNewman Member

    Joined:
    Oct 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hey! I'm a n00b here :P. I just bought a dedicated server w/ CPanel & WHM, and I'm trying to configure e-mail piping for osTicket. I read the readme, and did everything it asked me to, including moving the automail.pl file to the cgi-bin folder, chmodding it 755, setting up an email alias that forwards to |/server/path/to/file, aaaaand yeah it keeps coming back with a msg from the mail server saying "local delivery failed". Any ideas anyone?
     
  2. SNewman

    SNewman Member

    Joined:
    Oct 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    No one can help me?
     
  3. zella

    zella Member

    Joined:
    Aug 5, 2005
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I already installed osticket more than once and works fine.

    You need to pipe to : |/path/to/cgi-bin/automail.pl

    Just replace /path/to/ with your information and maintain the name of automail.pl

    Let me know if i can help you.

    Marc
     
  4. SNewman

    SNewman Member

    Joined:
    Oct 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I did just that, and it's not working. Maybe I'm uploading the .pl file in the wrong mode? Oh I should note, this isnt a standalone osTicket installation, its the one packaged with HCL v2
     
  5. tuxdesk

    tuxdesk Well-Known Member

    Joined:
    Oct 1, 2005
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    There is no need to move the script to cgi-bin. Tell the currect path in /etc/valiases/domain.com as show below.
    eg:
    #vi /etc/valiases/domain.com
    support@domain.com: "|/home/<username>/public_html/<osticket directoy>/automail.pl
     
  6. SNewman

    SNewman Member

    Joined:
    Oct 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ooooooh just one ". I was using two. Do I need to make a pop3 account for the one I am forwarding for or just an alias?
     
Loading...

Share This Page