The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

E-mail Question

Discussion in 'E-mail Discussions' started by Buiddoi, Jul 31, 2005.

  1. Buiddoi

    Buiddoi Member

    Joined:
    Jul 31, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello there,

    Before my box was doing fine with no problem but since I do the upgraded I've noticed that all of the domains under my box couldn't send or receive mail from webmail. I've tried to send a message, I received:

    There was an error sending your message: sendmail [/usr/sbin/sendmail] not executable

    I then looked into WHM and seeing that there were lot of email waiting to delivery but somehow it still in the queries, why? I tried to use the third party to check and send mail it work with no problem.

    Could someone please help!

    Thanks!
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    It is likely that the permission somehow was changed/modified. Change the permission to 755 and see if that helps.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The actual permissions for /usr/sbin/sendmail are:

    chmod +x /usr/sbin/sendmail
    chmod g+s /usr/sbin/sendmail
    chown root:mailtrap /usr/sbin/sendmail
     
  4. Buiddoi

    Buiddoi Member

    Joined:
    Jul 31, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thanks for the info but it's seem like there is no Sendmail folder or file exist under /usr/sbin/.... is there any ideas why ? where can I get that file ?

    Thankx!
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you don't have a /usr/sbin/sendmail then you should run:

    /scripts/updatenow
    /scripts/eximup --force
     
  6. Buiddoi

    Buiddoi Member

    Joined:
    Jul 31, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thankx it's work now :)

    Do you have any ideas why when I do an upgraded through WHM the Sendmail was deleted ?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No idea. I would expect it to be OK fro now on, though.
     
Loading...

Share This Page