The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

E-mail server problems

Discussion in 'E-mail Discussions' started by fdnven, Feb 18, 2006.

  1. fdnven

    fdnven Well-Known Member

    Joined:
    Feb 14, 2006
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    E-mail server problems (solved)

    So i finally got my DNS to read my site.

    I run a report from http://www.dnsreport.com

    I get a RED error when e-mail is concerned the error is thus:

    Connect to mail servers=
    ERROR: I could not complete a connection to any of your mailservers!

    mail.gotcanyons.net: Could not connect without glue or A record.

    If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail may work fine in this case but you will need to use testing tools specifically designed for such situations.

    Reverse DNS entries for MX records=

    ERROR: None of your mail server(s) seem to have reverse DNS (PTR) entries (I didn't get any responses for them). RFC1912 2.1 says you should have a reverse DNS for all your mail servers. It is strongly urged that you have them, as many mailservers will not accept mail from mailservers with no reverse DNS entry. You can double-check using the 'Reverse DNS Lookup' tool at the DNSstuff site (it contacts your servers in real time; the reverse DNS lookups in the DNS report use our local caching DNS server).


    I set gotcanyons.net as the MX entry in WHM.

    Any Ideas?
     
    #1 fdnven, Feb 18, 2006
    Last edited: Feb 19, 2006
  2. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    After looking at your DNS via a couple of sites:

    1) it doesn't appear that you have an A record for mail.gotcanyons.net
    For MX entries, the resolutions is thus: who handles mail? mail.gotcanyons.net; what's the IP for mail.gotcanyons.net? Dunno... that's what's missing.

    2) your nameserver records at your domain registrar and in your DNS account don't match... your DNS is missing ns6.easydns.net and remote3.easydns.com. These two servers are listed at your registrar, but not in your DNS settings. This can cause issues.

    3) reverse DNS for mail servers won't be able to work, even if configured, until #1 is fixed. It may or may not be correct right now.
     
  3. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    The issue was raised by me in one of the thread as to why the template doesn't have a A record for mail and then a MX record on that. The absence of this would cause a RED Flag at DNS report for all sites hosted on dedicated IP address, unless you manually do the changes.

    Anup
     
  4. fdnven

    fdnven Well-Known Member

    Joined:
    Feb 14, 2006
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
     
  5. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
     
  6. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    make sure there is a . after the net; that could make a difference.

    Also, forgot to mention that the report shows ns0.gotcanyons.net as the SOA nameserver, which doesn't exist.
     
  7. fdnven

    fdnven Well-Known Member

    Joined:
    Feb 14, 2006
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    I tried to add a . after the net it thru up a error. Her are some snapshots of my zone set-up.

    dns zone

    And snapshot of error:

    error
     
  8. fdnven

    fdnven Well-Known Member

    Joined:
    Feb 14, 2006
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Man i feel stupid now.

    All DNS info goes to my domain register ie easydns.

    I was trying to edit my zone in WMH

    Works great now.

    Thanks.
     
  9. Lyttek

    Lyttek Well-Known Member

    Joined:
    Jan 2, 2004
    Messages:
    770
    Likes Received:
    3
    Trophy Points:
    18
    Heh... yeah, things like that can be a head-slapper :)
     
Loading...

Share This Page