E-mails sent from cPanel don't reach recipients

zawack

Active Member
Jan 11, 2016
26
3
3
L'Orignal ON, Canada
cPanel Access Level
DataCenter Provider
Hi everyone!

I have issues when I send emails from my cPanel server to Hotmail and Gmail users, my emails don't reach the recipients mail box, the most of the time, my messages goes in the spam folder or it bounce back to me. Please note my IP was never used for sending spam. I read I need to setup DKIM, SPF and DMARC, for SPF I do it but its a little but more complicated for the DKIM and the DMARC. My domain have the registrar nameservers because when I set my VPS hostname as nameservers the informations never propagate even after waiting 48 hours, so my provider who is OVH Canada tell me to create a A record pointing to my VPS IP adress and park my domain at my registrar.

When I go to one of my cPanel account on my VPS and I go at Email Authentification, I go this message: Status: Enabled WARNING: The system cannot verify that this server is an authoritative nameserver for “zawack.ca)”.

I create an key and setup an TXT record at my registrar and in cPanel on my VPS with the key but I still get the error message above. For the SPF I got this: Enabled and Active (DNS Check Passed)


Do I did something wrong?

Thanks in advance for your help!

Guillaume
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
y domain have the registrar nameservers because when I set my VPS hostname as nameservers the informations never propagate even after waiting 48 hours, so my provider who is OVH Canada tell me to create a A record pointing to my VPS IP adress and park my domain at my registrar.
Hello :)

I suggest switching to your own private name servers if you want to take advantage of the automated addition of SPF and DKIM records through the cPanel interface. There's a guide on this at:

[Tutorial] Nameserver configuration on cPanel servers

You can then easily configure the SPF and DKIM records if the domain name uses your own private name servers.

Thank you.