E Pre Maintenance ended, however it did not exit cleanly (256). (without an error)

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
Hi,

Last night's upcp run off all(!) of our cPanel servers resulted in an "E Pre Maintenance ended, however it did not exit cleanly (256)" error:

Running:
Code:
[2018-01-27 04:55:07 +0100]   Detected version '11.68.0.27' from version file.
[2018-01-27 04:55:07 +0100]   Running version '11.68.0.27' of updatenow.
[2018-01-27 04:55:16 +0100]   Target version set to '11.68.0.27'
[2018-01-27 04:55:16 +0100]   Up to date (11.68.0.27)
Logfile snippet:
Code:
...
=> Log opened from cPanel Update (upcp) - Slave (10952) at Sat Jan 27 05:11:43 2018
[2018-01-27 05:11:43 +0100] E Pre Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened
=> Log closed Sat Jan 27 05:11:43 2018
[2018-01-27 05:11:44 +0100]   95% complete
[2018-01-27 05:11:44 +0100]   Running Standardized hooks
[2018-01-27 05:11:44 +0100]   100% complete
[2018-01-27 05:11:44 +0100]   
[2018-01-27 05:11:44 +0100]     cPanel update completed
[2018-01-27 05:11:44 +0100]   A log of this update is available at /var/cpanel/updatelogs/update.1517025302.log
[2018-01-27 05:11:44 +0100]   Removing upcp pidfile
...
>awk '$4=="E"' /var/cpanel/updatelogs/update.1517025302.log
Code:
[2018-01-27 05:04:04 +0100] E    [/usr/local/cpanel/scripts/find_outdated_services] The â/usr/local/cpanel/scripts/find_outdated_servicesâ
                                                          [2018-01-27 05:11:43 +0100] E Pre Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened
>/usr/local/cpanel/scripts/find_outdated_services
Code:
Looking for outdated services â¦
The system did not find any outdated services.
What's wrong here?
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
An update: Tonight's upcp run did not have any errors. We've not altered or changed anything in the mean time.
This has already been the second time upcp reported an error, when there apparently was none. Please fix this as this is quite annoying.
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
@24x7server: As previously mentioned, the servers did not have any error(s) the next night's run of upcp, so I'm just leaving it at that.
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
And tonight once again: One of our cPanel servers reported a problem during it's run of upcp when there apparently was none:
Still running:
Code:
...
[2018-01-29 04:55:07 +0100]   Detected version '11.68.0.27' from version file.
[2018-01-29 04:55:07 +0100]   Running version '11.68.0.27' of updatenow.
[2018-01-29 04:55:08 +0100]   Retrieved public key from vendor: cpanel, category: development, url: https://securedownloads.cpanel.net/cPanelDevelopmentKey.asc
[2018-01-29 04:55:08 +0100]   Retrieved public key from vendor: cpanel, category: release, url: https://securedownloads.cpanel.net/cPanelPublicKey.asc
[2018-01-29 04:55:09 +0100]   Retrieved public key from vendor: cpanel, category: development-sts, url: https://securedownloads.cpanel.net/STSTestKey.asc
[2018-01-29 04:55:17 +0100]   Target version set to '11.68.0.27'
[2018-01-29 04:55:17 +0100]   Up to date (11.68.0.27)
...
Log snippet:
Code:
=> Log opened from cPanel Update (upcp) - Slave (22186) at Mon Jan 29 05:06:14 2018
[2018-01-29 05:06:14 +0100] E Pre Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened
=> Log closed Mon Jan 29 05:06:15 2018
[2018-01-29 05:06:15 +0100]   95% complete
[2018-01-29 05:06:15 +0100]   Running Standardized hooks
[2018-01-29 05:06:15 +0100]   100% complete
[2018-01-29 05:06:15 +0100]  
[2018-01-29 05:06:15 +0100]     cPanel update completed
[2018-01-29 05:06:15 +0100]   A log of this update is available at /var/cpanel/updatelogs/update.1517198101.log
>awk '$4=="E"' /var/cpanel/updatelogs/update.1517198101.log
Code:
[2018-01-29 04:57:45 +0100] E    [/usr/local/cpanel/scripts/find_outdated_services] The â/usr/local/cpanel/scripts/find_outdated_servicesâ
                                                          [2018-01-29 05:06:14 +0100] E Pre Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened
>/usr/local/cpanel/scripts/find_outdated_services
Code:
Looking for outdated services â¦
The system did not find any outdated services.
This false positive is very frustrating. Please fix this.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello,

Could you open the specific update log associated with the failed update and browse to the section where "/usr/local/cpanel/scripts/find_outdated_services" runs to see what appears after the attempt to run that script during the update? It's possible the output in the update log is different compared to when you run it manually.

Thank you.
 

Bdzzld

Well-Known Member
Apr 3, 2004
412
5
168
@cPanelMichael: upcp has only been run automatically and not manually.
This is what a snippet of the log looks like:
Code:
...
[2018-01-29 04:57:25 +0100]   26% complete
[2018-01-29 04:57:25 +0100]    - Finished in 33.975 seconds
[2018-01-29 04:57:25 +0100]   Processing: Restarting any outdated services
[2018-01-29 04:57:25 +0100]    - Processing command `/usr/local/cpanel/scripts/find_outdated_services --always-restart`
[2018-01-29 04:57:45 +0100]      [/usr/local/cpanel/scripts/find_outdated_services] Looking for outdated services â¦
[2018-01-29 04:57:45 +0100] E    [/usr/local/cpanel/scripts/find_outdated_services] The â/usr/local/cpanel/scripts/find_outdated_servicesâ
                                   [2018-01-29 04:57:45 +0100]   The Administrator will be notified to  completess output when this scriptt
[2018-01-29 04:57:45 +0100]    - Finished command `/usr/local/cpanel/scripts/find_outdated_services --always-restart` in 20.495 seconds
[2018-01-29 04:57:45 +0100]   Processing: Running platform specific optimizations
[2018-01-29 04:57:45 +0100]    - Processing command `/usr/local/cpanel/scripts/vps_optimizer`
[2018-01-29 04:57:45 +0100]    - Finished command `/usr/local/cpanel/scripts/vps_optimizer` in 0.086 seconds
[2018-01-29 04:57:45 +0100]   27% complete
...
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Hello,

Could you open a support ticket using the link in my signature so we can take a closer look?

Thank you.