Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EA 3.14 - No caching applications???

Discussion in 'EasyApache' started by Reado, Jul 11, 2012.

  1. Reado

    Reado Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    191
    Likes Received:
    8
    Trophy Points:
    68
    Location:
    United Kingdom
    cPanel Access Level:
    DataCenter Provider
    EA 3.14 is out, but X-Cache and eAccelerator options have been removed?! No mention of this in the change log!

    What's going on?
     
  2. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    143
    Hi,

    Would you mind opening a support case on the issue and sending me the case number? I'll be happy to take a look. Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Reado

    Reado Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    191
    Likes Received:
    8
    Trophy Points:
    68
    Location:
    United Kingdom
    cPanel Access Level:
    DataCenter Provider
    One of your colleagues is already looking at this. He says this is an "undocumented" change and says I now need to be using PHP Extension Manager to install X-Cache.

    However I have just discovered that if extensions are installed using this tool, they are removed from the system without warning if you run EasyApache again. In addition it appears that extensions are not updated automatically either, since this used to be handled by EasyApache.

    So it appears I have found the reason why EA 3.14 failed QA so many times!!! Doesn't make sense why it was released??
     
  4. Reado

    Reado Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    191
    Likes Received:
    8
    Trophy Points:
    68
    Location:
    United Kingdom
    cPanel Access Level:
    DataCenter Provider
    Latest from support is that both QA and Development are working to resolve these issues.
     
  5. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    143
    Reado,

    I believe support may have mis-spoke when they suggested this was an undocumented change, as the intended behavior is to remove those accelerators if 5.4 is chosen as the active handler. Significant changes have been made between EA 3.13 and 3.14.

    A new EA build should be published shortly to address the issue. Thanks for the report.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Reado

    Reado Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    191
    Likes Received:
    8
    Trophy Points:
    68
    Location:
    United Kingdom
    cPanel Access Level:
    DataCenter Provider
    This behavior occurs with any PHP version - in this case all I wanted was PHP 5.3.14 and on the next screen there was no option for X-Cache or the other caching extensions!
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,160
    Likes Received:
    370
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:

    I believe this is now resolved. Have a look to confirm when you have a moment.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice