The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EA 3.4.2 does not include mod_security 2.6

Discussion in 'Security' started by Reado, Jul 19, 2011.

  1. Reado

    Reado Well-Known Member

    Joined:
    Sep 8, 2009
    Messages:
    161
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    United Kingdom
    cPanel Access Level:
    DataCenter Provider
    The EA changelog for 3.4.2 says mod_security 2.6.0 has been added for Apache 2.2. However when I run /scripts/easyapache and look for mod_security as an option, it still says "v2.5.13 for Apache 2.x". After running the EA installer anyway and checking the logs, mod_security 2.6 has not been installed:

    Code:
    [Tue Jul 19 09:03:22 2011] [notice] caught SIGTERM, shutting down
    [Tue Jul 19 09:03:25 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Tue Jul 19 09:03:25 2011] [notice] ModSecurity for Apache/2.5.13 (http://www.modsecurity.org/) configured.
    [Tue Jul 19 09:03:25 2011] [notice] Original server signature: Apache
    [Tue Jul 19 09:03:26 2011] [notice] Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 Apache configured -- resuming normal operations
    Please could this be fixed?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Greetings, Reado. I've found the same here. I've just put in a ticket for clarification on this and will post back when I find out more.

    Thanks!
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This is a clerical error. EasyApache 3.4 only comes with mod_security 2.5.13. We'll get the change log updated.
     
Loading...

Share This Page