Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

In Progress [EA-8399] EA4 Experimental PHP Memcached Extensions Stop Working After Latest Update

Discussion in 'EasyApache' started by matt1206, Apr 19, 2019.

Tags:
  1. matt1206

    matt1206 Active Member

    Joined:
    Dec 20, 2011
    Messages:
    30
    Likes Received:
    1
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    Code:
    ea-php71-php-memcached-3.0.2-1.1.229.cpanel.x86_64
    ea-php56-php-memcached-2.2.0-1.4.225.cpanel.x86_64
    ea-php70-php-memcached-3.0.2-1.5.220.cpanel.x86_64
    On the most recent update, memcached is no longer working via the EA4 experimental packages. Memcache works, but not the above provided memcached.

    Phpinfo shows it including the memcached.ini file, which calls the correct .so file, however, it's not actually loading.

    Code:
    # ./php -m                                                   [PHP Modules]
    bcmath
    bz2
    Core
    ctype
    curl
    date
    dom
    exif
    fileinfo
    filter
    ftp
    gd
    gettext
    gmp
    hash
    iconv
    igbinary
    imagick
    intl
    ionCube Loader
    json
    libxml
    mbstring
    mcrypt
    memcache
    mysqli
    mysqlnd
    openssl
    pcntl
    pcre
    PDO
    pdo_mysql
    pdo_sqlite
    Phar
    posix
    readline
    Reflection
    session
    SimpleXML
    SPL
    sqlite3
    standard
    timezonedb
    tokenizer
    wddx
    xml
    xmlreader
    xmlrpc
    xmlwriter
    xsl
    Zend OPcache
    zip
    zlib
    
    [Zend Modules]
    Zend OPcache
    the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured)
    Code:
    # cat /opt/cpanel/ea-php70/root/etc/php.d/memcached.ini
    ; Enable yaml extension module
    extension=memcached.so
    
    ; for further documentation on settings see
    ; http://php.net/manual/en/memcache.ini.php
    
    ; use memcache to store PHP sessions
    ; session.save_handler = "memcache"
    ; session.save_path = "tcp://localhost:11211"
    
    ; use a different default memcche port
     
  2. Adrian Boldor

    Adrian Boldor Registered

    Joined:
    Apr 19, 2019
    Messages:
    1
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Romania
    cPanel Access Level:
    Root Administrator
    The workaround that works and I got from Cpanel Support is:

    The workaround here, for now, is to remove the Experimental RPMs we provide and then exclude the Experimental RPMs and then install the libmemcached and libmemcached-devel RPMs provided by CentOS yum repos.

    The following can be used to disable those from the EA4 repos.

    rpm -ev --nodeps libmemcached
    yum install --disablerepo=EA4-experimental libmemcached
    echo 'exclude=libmemcached' >> /etc/yum.repos.d/EA4-experimental.repo
     
    cPanelMichael and matt1206 like this.
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    46,992
    Likes Received:
    2,122
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Internal case EA-8399 is open to address an issue where the ea-php##-php-memcached extensions fail to load after the libmemcached package is moved to the ea-libmemcached namespace upon applying the latest EA4 experimental update.

    I'll monitor the case and update this thread with more information as it becomes available. In the meantime, you can review the workaround steps in the previous post to switch over to the CentOS libmemcached and libmemcached-devel RPMs.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    matt1206 and cPAusaf like this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice