The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EA installed wrong PHP version?

Discussion in 'General Discussion' started by BPmedia-David, Feb 5, 2008.

  1. BPmedia-David

    BPmedia-David Member

    Joined:
    Sep 11, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I went into apache update, and installed PHP5 as the primary version, with PHP4 using cgi (tried dso too). Everything seemed to work fine, until I double checked the phpinfo file, and it shows that PHP4 is installed.

    Any Ideas?

    WHM 11.15.0 cPanel 11.17.0-R19434
     
  2. markhard

    markhard Well-Known Member

    Joined:
    Apr 22, 2004
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    16
    have you tried to change the extension from .php to php5?

    if i'm not mistaken cpanel differentiate which php should be used by the extension of the file
     
  3. BPmedia-David

    BPmedia-David Member

    Joined:
    Sep 11, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    It's set to use PHP5 by default for all .php extensions.

    .php4 files should go to PHP4 though. I'm sure a .php5 extension would work, however, we need 5 to be the default.
     
  4. BPmedia-David

    BPmedia-David Member

    Joined:
    Sep 11, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I submitted a ticket to cPanel.... When I tried un-installing PHP4, it didn't work.... I've tried everything. If anyone has any suggestions/comments they'd be appreciated.


    edit: this issue has been sorted out by the cpanel staff. I was very impressed with the response time.
     
    #4 BPmedia-David, Feb 6, 2008
    Last edited: Feb 7, 2008
Loading...

Share This Page