ea-nginx dependency over ea-modsec30 differs in CentOS and CloudLinux

Indianets

Well-Known Member
PartnerNOC
Jun 13, 2008
69
0
56
cPanel Access Level
Root Administrator
Hello,

On a CentOS 7 server I installed ea-nginx without any issues with modsec2 working with apache.

Bash:
# cat /etc/redhat-release
CentOS Linux release 7.9.2009 (Core)

# rpm -qa | grep -e nginx -e mod_*sec
ea-apache24-mod_security2-2.9.3-12.12.6.cpanel.x86_64
ea-modsec-sdbm-util-0.02-1.1.29.cpanel.x86_64
cpanel-ng-whm-nginx-manager-8-1.cp1196.noarch
ea-nginx-1.20.0-1.1.1.cpanel.x86_64
But on a CloudLinux 7 server I cannot do the same. ea-nginx has a dependency on ea-modsec30 which conflicts with ea-apache24-mod_security2.

Bash:
Resolving Dependencies
--> Running transaction check
---> Package ea-nginx.x86_64 3:1.19.7-3.el7.cloudlinux will be installed
--> Processing Dependency: ea-modsec30 for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
--> Processing Dependency: ea-modsec30-connector-nginx for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
--> Running transaction check
---> Package ea-modsec30.x86_64 1:3.0.4-6.el7.cloudlinux will be installed
---> Package ea-modsec30-connector-nginx.x86_64 1:1.0.1-1.el7.cloudlinux will be installed
--> Processing Conflict: 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64 conflicts mod_security
--> Processing Conflict: 1:ea-modsec30-3.0.4-6.el7.cloudlinux.x86_64 conflicts ea-apache24-mod_security2
--> Finished Dependency Resolution

Is there anything I am missing? Why this different behavior and which one is the right behavior?

Thanks
 

ankeshanand

Well-Known Member
Mar 29, 2021
66
15
8
India
cPanel Access Level
Root Administrator
Hello,

On a CentOS 7 server I installed ea-nginx without any issues with modsec2 working with apache.

Bash:
# cat /etc/redhat-release
CentOS Linux release 7.9.2009 (Core)

# rpm -qa | grep -e nginx -e mod_*sec
ea-apache24-mod_security2-2.9.3-12.12.6.cpanel.x86_64
ea-modsec-sdbm-util-0.02-1.1.29.cpanel.x86_64
cpanel-ng-whm-nginx-manager-8-1.cp1196.noarch
ea-nginx-1.20.0-1.1.1.cpanel.x86_64
But on a CloudLinux 7 server I cannot do the same. ea-nginx has a dependency on ea-modsec30 which conflicts with ea-apache24-mod_security2.

Bash:
Resolving Dependencies
--> Running transaction check
---> Package ea-nginx.x86_64 3:1.19.7-3.el7.cloudlinux will be installed
--> Processing Dependency: ea-modsec30 for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
--> Processing Dependency: ea-modsec30-connector-nginx for package: 3:ea-nginx-1.19.7-3.el7.cloudlinux.x86_64
--> Running transaction check
---> Package ea-modsec30.x86_64 1:3.0.4-6.el7.cloudlinux will be installed
---> Package ea-modsec30-connector-nginx.x86_64 1:1.0.1-1.el7.cloudlinux will be installed
--> Processing Conflict: 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64 conflicts mod_security
--> Processing Conflict: 1:ea-modsec30-3.0.4-6.el7.cloudlinux.x86_64 conflicts ea-apache24-mod_security2
--> Finished Dependency Resolution

Is there anything I am missing? Why this different behavior and which one is the right behavior?

Thanks
Its processing the Conflict by Disabling/Enabling modules and its normal behaviour.
Code:
--> Processing Conflict: 2:ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64 conflicts mod_security
--> Processing Conflict: 1:ea-modsec30-3.0.4-6.el7.cloudlinux.x86_64 conflicts ea-apache24-mod_security2
EasyApache4 has Inbuilt profile pre-made for CloudLinux+All PHP Options+NGINX .Maybe, You should try directly Provisioning it because there are no conflicts in that!
 

Indianets

Well-Known Member
PartnerNOC
Jun 13, 2008
69
0
56
cPanel Access Level
Root Administrator
EasyApache4 has Inbuilt profile pre-made for CloudLinux+All PHP Options+NGINX .Maybe, You should try directly Provisioning it because there are no conflicts in that!
It has nothing to do with original question in this thread.

Let someone from cPanel have a look so that they can replicate the same on test boxes having CentOS and CloudLinux.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,768
587
273
cPanel Access Level
Root Administrator
Hey there! I created a 96.0.1 cPanel server running on CloudLinux 7. The only warning I got when installing the ea-nginx package was to choose the version of Ruby Passenger, either 2.4 or 2.7. After that, the provision process went through just fine with no dependency problems. I also confirmed I had this version of ModSecurity installed:

ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64

Could you run this on your server and post the results?

Code:
rpm -qa | grep mod_security
as this would show all the packages and potentially let us see the conflict.
 

Indianets

Well-Known Member
PartnerNOC
Jun 13, 2008
69
0
56
cPanel Access Level
Root Administrator
Hey there! I created a 96.0.1 cPanel server running on CloudLinux 7. The only warning I got when installing the ea-nginx package was to choose the version of Ruby Passenger, either 2.4 or 2.7. After that, the provision process went through just fine with no dependency problems. I also confirmed I had this version of ModSecurity installed:

ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64

Could you run this on your server and post the results?

Code:
rpm -qa | grep mod_security
as this would show all the packages and potentially let us see the conflict.
Hello Rex,

I have the exact same version of mod_security2 version as yours.

Code:
# rpm -qa | grep mod_security
ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64
ea-apache24-mod_security2-mlogc-2.9.3-4.el7.cloudlinux.x86_64
Just for clarity, I have sdbm utility as well which is a dependency of modsec2 --

Code:
# rpm -qa | grep -e nginx -e mod_*sec
ea-apache24-mod_security2-2.9.3-4.el7.cloudlinux.x86_64
ea-apache24-mod_security2-mlogc-2.9.3-4.el7.cloudlinux.x86_64
cpanel-ng-whm-nginx-manager-8-1.cp1196.noarch
ea-modsec-sdbm-util-0.02-1.el7.cloudlinux.1.x86_64
Could you please check the version of ea-nginx and ea-modsec30 on your box, I am getting these --

Code:
# yum list ea-nginx ea-modsec30*
...
Available Packages
ea-modsec30.x86_64                                                                                     1:3.0.4-6.el7.cloudlinux                                                                       cl-ea4
ea-modsec30-connector-nginx.x86_64                                                                     1:1.0.1-1.el7.cloudlinux                                                                       cl-ea4
ea-nginx.x86_64                                                                                        3:1.19.7-3.el7.cloudlinux                                                                      cl-ea4
Thanks
 

Indianets

Well-Known Member
PartnerNOC
Jun 13, 2008
69
0
56
cPanel Access Level
Root Administrator
@cPRex

It seems the problem is with the ea-nginx in cl-ea4 stable repo. I just tried installing from cl-ea4-testing repo and it didn't have the ea-modsec30 dependency.

Code:
# yum list ea-nginx --enablerepo=cl-ea4-testing
...
Available Packages
ea-nginx.x86_64                                                                          3:1.19.8-3.el7.cloudlinux.1                                                                          cl-ea4-testing
Seem has been resolved in 1.19.8-3 of cloudlinux version.

Also, the cPanel provided version is even higher (on CentOS) - ea-nginx-1.20.0-1.1.1.cpanel.x86_64.

Thanks
 
Last edited: