SOLVED .ea-php-cli.cache files with 777 permissions

webstuff

Well-Known Member
Jul 19, 2011
76
2
58
Not sure if this has to do with a update.. But I been finding these files recently .ea-php-cli.cache files with 777 permissions

Anyone know what they have to do with? maybe a hack of some sort? the times do not make much sense tried going through the visitors logs and didn't see much.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,911
2,234
363
Hello @webstuff,

Those files stem from a recent change to PHP-CLI published as part of an EasyApache 4 release:

EasyApache 4 Release Notes - EasyApache 4 - cPanel Documentation

ea-php-cli
ZC-4400 - Rewrite ea-php-cli in perl
We've updated the corresponding document below to reflect the use of those files:

EasyApache 4 and the ea-php-cli Package - EasyApache 4 - cPanel Documentation

The .ea-php-cli.cache symlink
The first time you call one of the ea-php-cli binaries, the system creates the .ea-php-cli.cache symlink to the PHP version that the directory requires. This symlink provides a quick way for the system to determine the proper version of PHP and reads as broken by design. For example, if the PHP script requires PHP 7.0, then the symlink will point to ea-php70.

Important:

We strongly recommend that you do not delete these symlinks. The system creates broken symlinks by design and will recreate any removed symlinks the next time that you run the script. You can safely ignore them.
Thank you.
 
  • Like
Reactions: webstuff