Operating System & Version
centos 8
cPanel & WHM Version
92

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Hi,
i install and configure a new Centos8 and WHM/cPanel 92 installation with easy apache 4. I really need to have ea-php56 package installed however i receive the following result:

Bash:
yum install ea-php56
Last metadata expiration check: 0:06:23 ago on Sat Feb  6 11:43:57 2021.
No match for argument: ea-php56
Error: Unable to find a match: ea-php56
Can you please help me for that?

One more question as for the release date of 94 version in productive way. Is this date available to public?
 
Last edited by a moderator:

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
I can not believe that i must pay more for that. Unable that there is no any alternative. This is for an encrypted php5.6 compatible software where i can not edit and make it compatible with php 7x
 

andrew.n

Well-Known Member
Jun 9, 2020
633
183
43
EU
cPanel Access Level
Root Administrator
You would be better with CentOS 7 anyway as support for CentOS 8 will end in a year :(
 

andrew.n

Well-Known Member
Jun 9, 2020
633
183
43
EU
cPanel Access Level
Root Administrator
Yes PHP 5.6 is still supported by default without CloudLinux on CentOS 7 and CentOS 7 is still supported by cPanel by the end of 2024.
 

andrew.n

Well-Known Member
Jun 9, 2020
633
183
43
EU
cPanel Access Level
Root Administrator
cPanel supports CentOS 8 till the end of it's lifecycle i.e 2021 Dec 31 (About/Product - CentOS Wiki)
CloudLinux do offer extended support for CentOS 6 which is EOL already for an extra price:


however as far as I know they not aim to offer extended support for CentOS 8 once it becomes EOL.

As for CentOS 7 cPanel do support it till the end of it's lifecycle (2024) and I do believe CloudLinux will offer extended support beyond that for an extra charge just like for CentOS 6 now. Furthermore CloudLinux is developing it's own OS which cPanel will support (beyond Ubuntu as a new OS supported by cPanel):


CloudLinux OS is/will be free.
 

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Thank you @andrew.n, unfortunately cloudlinux is not free of charge. I can see almost 170 dollars/year for one server. I will try centos 7 + whm as it's important to keep having 5.6 version of php as well. I assumed that centos 8 lifecycle will be longer than centos 7 that's why i followed the option of whm and centos 8.
 

andrew.n

Well-Known Member
Jun 9, 2020
633
183
43
EU
cPanel Access Level
Root Administrator

andrew.n

Well-Known Member
Jun 9, 2020
633
183
43
EU
cPanel Access Level
Root Administrator
Michael, feel free to visit the blog post I linked and see it yourself :)
 

Michaelit

Well-Known Member
Aug 5, 2015
82
9
58
Greece
cPanel Access Level
Root Administrator
Aha i see " As we already maintain CloudLinux OS, we plan to release a free, open-sourced, community-driven, 1:1 binary compatible fork of RHEL® 8 (and future releases) in the Q1 of 2021. "
 
  • Like
Reactions: andrew.n

kodeslogic

Well-Known Member
Apr 26, 2020
331
126
118
IN
cPanel Access Level
Root Administrator

Attachments

goodmove

Well-Known Member
May 12, 2003
643
4
168
Can you please give me more information about that? If i move to Centos 7 will ea4 support 5.6 version of php?
Yes, it does. Centos 7 + Cpanel supports PHP versions prior to 7.2, including 5.6, as well as MySQL 5.7 which has an EOL of 21 Oct. 2023. Centos 8 (+ AlmaLinux) + Cpanel does not support either of those.