DennisMidjord

Well-Known Member
Sep 27, 2016
283
43
78
Denmark
cPanel Access Level
Root Administrator
@cPanelAnthony I have a small question regarding the article.
ALT-PHP includes PHP versions that CloudLinux provides along with their PHP Selector feature.
These versions of PHP are often hardened and patched against vulnerabilities to allow users to continue to use applications that require outdated PHP versions.
A few years ago, I asked CloudLinux whether or not they also patched the ea-packages, and they said they did. Is this no longer the case?
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
583
54
103
Houston, TX
cPanel Access Level
Root Administrator
@cPanelAnthony I have a small question regarding the article.


A few years ago, I asked CloudLinux whether or not they also patched the ea-packages, and they said they did. Is this no longer the case?
For outdated PHP versions, prior to 7.0, you would need to use alt-php since there would be no patched/support alt-php versions for these older PHP installations.
 

microvax

Well-Known Member
Mar 4, 2021
50
4
8
Lima
cPanel Access Level
Root Administrator
If you run the yum info ea-php56
command you will receive this result

Code:
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 4:04:47 ago on Mon 22 Nov 2021 08:53:34 PM EST.
Installed Packages
Name         : ea-php56
Epoch        : 1
Version      : 5.6.40
Release      : 4.el8.cloudlinux.1
Architecture : x86_64
Size         : 0.0 
Source       : ea-php56-5.6.40-4.el8.cloudlinux.1.src.rpm
Repository   : @System
From repo    : cl-ea4
Summary      : Package that installs PHP 5.6
License      : GPLv2+
Description  : This is the main package for ea-php56 Software Collection,
             : that install PHP 5.6 language.