The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EA3 & FCGI Best Option?

Discussion in 'EasyApache' started by Moobs, Mar 21, 2017.

Tags:
  1. Moobs

    Moobs Registered

    Joined:
    Mar 21, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    United States
    cPanel Access Level:
    Root Administrator
    I'd like to speed up my e-commerce site by changing my VPS to fcgi & php7. My host has been pretty apprehensive about running fcgi on my server in regards to security & stability with EA4. But he was also brushing off EA3 & fcgi since EA3 has been deprecated.

    Is EA3 still the way to go when using fcgi & php7? Is there any reason why this would not be good for the next couple years or until EA4 is stable with fcgi?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,288
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    cPanel & WHM will not support EasyApache 3 in version 64 or later. Additionally, EasyApache 3 is scheduled for deprecation in January of 2018, when cPanel & WHM version 62 reaches End of Life.

    I'd recommend using EA4 with mod_fcgid as documented at:

    Apache Module: FCGId - EasyApache 4 - cPanel Documentation

    Thank you.
     
  3. bejbi

    bejbi Well-Known Member

    Joined:
    Jan 20, 2006
    Messages:
    94
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Poland
    cPanel Access Level:
    DataCenter Provider
    If You are using CloudLinux, lsapi_mod is even better option than fastcgi.

    Wojtek
     
Loading...

Share This Page