webmasteryoda

Well-Known Member
Apr 3, 2013
98
7
58
Serbia
cPanel Access Level
Root Administrator
Hello

I want to upgrade to EA4, but I am currently using the old profile (Apache 2.2, PHP 5.3).

I understand that EA4 doesnt support old versions of Apache and PHP. So...

What do I have to do?

Update Apache and PHP through EA3, and than upgrade to EA4
or
/scripts/migrate_ea3_to_ea4 --run
(and thats all???)

If I run the migration script with old versions of Apache and PHP running, what version will I end up with after the upgrade process?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

The EA4 conversion process will automatically update Apache to version 2.4. You are prompted with information about the new default PHP version when running the conversion script. Once the conversion is complete, you can update the default PHP versions and handlers via:

MultiPHP Manager for WHM - Documentation - cPanel Documentation

Thanks!
 
  • Like
Reactions: webmasteryoda

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
I'm happy to see the conversion went well. Thank you for updating us with the outcome.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

What's output to /usr/local/apache/logs/error_log when you notice that error message?

Thank you.
 

webmasteryoda

Well-Known Member
Apr 3, 2013
98
7
58
Serbia
cPanel Access Level
Root Administrator
I think I have found it.

[13-Feb-2017 21:31:12 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 196608 bytes) in /home/xxxxxxx/public_html/wp-content/themes/betheme/functions/plugins/visual-composer.php on line 775

How can I raise the memory limit?
 

webmasteryoda

Well-Known Member
Apr 3, 2013
98
7
58
Serbia
cPanel Access Level
Root Administrator
Fixed multiple problems.

This one left to fix:

Few websites on my server output this message:
Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

-----------------

PS - I am writing this for other users that want to upgrade from EA3 to EA4. There are some issues on shared servers. Carefully...
 

webmasteryoda

Well-Known Member
Apr 3, 2013
98
7
58
Serbia
cPanel Access Level
Root Administrator
Yes. That one is also fixed.

This Wordfence code in htaccess was the problem:
Code:
# Wordfence WAF
<IfModule mod_suphp.c>
    suPHP_ConfigPath '/home/preduzet/public_html'
</IfModule>
<Files ".user.ini">
<IfModule mod_authz_core.c>
    Require all denied
</IfModule>
<IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
</IfModule>
</Files>

# END Wordfence WAF
I have temporary removed it and all worked!
Now I just have to check if WF is working properly and what was the problem with that htaccess code.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463

webmasteryoda

Well-Known Member
Apr 3, 2013
98
7
58
Serbia
cPanel Access Level
Root Administrator
Thanks Michael

This line
Code:
<IfModule mod_suphp.c> suPHP_ConfigPath '/home/xxxxxxxx/public_html' </IfModule>
is something that Worfence plugin inserts into htaccess while configuring the WP firewall.

But, in the later versions of Wordfence they removed this line. (all previous installs did not removed it automatically)
So, if you update Wordfence to a newer version, and if you are using PHP 5.3 and want to upgrade to PHP 5.4 or later - you have to remove it manually, as Wordfence is not doing that automatically.
 
  • Like
Reactions: cPanelMichael